Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a server running on Windows 7 Professional and want to manage it with my Mac. I don't have a second monitor so Remote Desktop is just perfect.

PC and Mac share the same local network at home. I have a WiFi router and both of them have access to the internet.

I downloaded Remote Desktop Connection for Mac, a free program from Microsoft. My router has a DHCP table where my PC is listed with the IP 192.168.1.39. Remote Desktop Connections are activated in Windows (the medium setting, less secure).

When connecting to my PC, I get this error: enter image description here

Finder does list my PC, but says "Connection Failed":

enter image description here

EDIT: After activating Remote Desktop Connections on the PC, I now get this prompt when trying to connect from the Mac: enter image description here

What kind of credentials are they really asking for? My windows account name + password does not work here. And what's up with the domain? By default the IP of my PC was entered there.

What must I do to make this work? Do you know of any complete tutorial that also tackles the networking problem which is probably the root cause?

share|improve this question

migrated from serverfault.com Feb 1 '11 at 12:29

This question came from our site for professional system and network administrators.

1 Answer 1

First, note that the Windows 7 Home editions don't include Remote Desktop, so if you have Home Basic or Home Premium then you're out of luck.

Assuming you have Windows 7 Professional, Enterprise or Ultimate edition, you'll still need to enable Remote Desktop, and you'll find instructions for doing so here.

share|improve this answer
    
Have the Professional edition :) Thanks for the link! How can I fix the networking problem so the Mac can actually contact the PC? –  BugAlert Feb 1 '11 at 11:33
    
Updated my question with progress. Still not working :( –  BugAlert Feb 1 '11 at 11:45
    
YEAH! AWESOME! I just had to remove the -PC from my user name. Seems to be some kind of weird, stupid networking convention to add that. As soon as I tried to connect with the name I actually used for my account, the RDC opened up. Thanks a lot! –  BugAlert Feb 1 '11 at 11:50
    
@BugAlert: The username-PC name is the computer name and not your username. Right click on Computer and select Properties to confirm this. You shoud be able to use the computer name instead of the IP address when connecting (locally). –  paradroid Feb 1 '11 at 12:34
    
User Name: Should be the name of a user on the target machine. Domain: Should be the name of the target machine (assuming you don't have an active directory domain set up at home.) –  Chris Nava Feb 1 '11 at 15:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.