Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an always on broadband internet connection. I connected it to my Linksys router, and from there I connected it to the LAN card of the computer. I am not sure my confiurations are perfect.

I can see the LAN is connected from the mouse over of the lan icon on task bar saying "status connected". But there is no internet in the browser.

The same wifi router is transmitting internet and I can browse via my laptops.

share|improve this question

migrated from serverfault.com Aug 18 '09 at 8:15

This question came from our site for professional system and network administrators.

add comment

7 Answers

Are there any rules set up for DHCP through LAN on your router?

Do you have a properly set IP Address? (IP, Subnet Mask, Correct Gateway and DNS servers?)

Did you try setting your network card to automatically get IP-Address?

Can you give us more information on the router and its settings?

share|improve this answer
    
Are there any rules set up for DHCP through LAN on your router? No Do you have a properly set IP Address? (IP, Subnet Mask, Correct Gateway and DNS servers?) how can i check this? Did you try setting your network card to automatically get IP-Address? how can i do this? Can you give us more information on the router and its settings? what info u need ? –  SmartestVEGA Aug 18 '09 at 7:14
    
+1 Linksys devices by default run a DHCP server - simplest solution is usually just to re-configure your PC network to use DHCP, which from memory windows just say "automatically detect settings" or similar. –  Disabled Leopard Aug 18 '09 at 7:16
    
you can check ip configuration in your Network settings in the control panel OR on WinVista/Win7 you can see them in the Network and Sharing center under the left side menu "Change adapter settings" –  Shaharyar Aug 18 '09 at 7:18
    
in my network connection i can see two networks ... one is in the name "1394 connection 4" and other is "Local area connection 2" which one i neeed to take? –  SmartestVEGA Aug 18 '09 at 7:21
    
i went to the tcp/ip setting its selected as "Automatically detect connection" –  SmartestVEGA Aug 18 '09 at 7:23
show 5 more comments

you may need to cold set your modem, unplug the lan and all cables going into or out of the modem, leave it off for 10 minutes then plus the power in, and the outside internet in line into the router then plug in the lan cables good luck

share|improve this answer
add comment

The easiest way is just to do a system restore to the date it stopped working, minus one day, to be sure. I had the same problem for 2 weeks till it just hit me to do that and am back on already ;)

share|improve this answer
add comment

I have a problem with one of my Linksys routers where two of the LAN ports on the back are bad. Cables show link, but no traffic flows -- not even DHCP or DNS.

Perhaps you have a bad LAN jack. Try moving your LAN cable around to different jacks on the back of the router.

share|improve this answer
    
This could solve the problem unless the Internet jack is bad (from modem). I've had that one before... nice problem to troubleshoot. –  Travis Aug 18 '09 at 15:34
    
The OP says that WiFi computers work fine; it's the PC hooked into the LAN jack that doesn't work. –  Barry Brown Aug 18 '09 at 19:13
add comment

Try reseting your internet settings back to default.

"Control Panel" >> "Internet Options" >> "Advanced" tab >> "Reset"

share|improve this answer
add comment

If your two wireless laptops are working properly, then you've not setup something properly on the computer.

Control Panel -> Network Connections.

If you're on Windows Vista, You'll need:

Control Panel -> Network and Sharing Center -> Manage Network Connections

Right click on the wired connection (it'll normally be called Local Area Connection) or similar, and hit properties.

Scroll down to "Internet Protocol (TCP/IP)" and click it, then click Properties. (Vista will probably make a distinction on version 4 vs. version 6, we're looking for version 4 here).

Compare the settings at the TCP/IP Properties screen on your laptop versus that of the PC that doesn't work.

The only thing that should be different is the IP address, assuming you're manually setting addresses. Chances are you have a typo that requires fixing here.

If that doesn't work, right click on the Local Area Connection and click "Repair". This will perform all the basic maintenance you need on the connection (ip release, ip renew, flush dns, etc) and should help in getting it working.

share|improve this answer
add comment

As others mentions your computer should be setup to automatically recieve and IP address via DHCP. To find out go to Control panel>>Network Connections and right click on the connection (probably local area connection #2 from you above comments). Go to Properties. Then select Internet Protocol (Tcp/IP) and go to settings. There will be an option to select automatically receive and address. If that is not the right adapter try the others as well see. It is unlikely that setting them all to this will do any harm.

now if you still cant get online you should be able to log into the linksys router's control panel and see if it has received an address from your cable modem (I imagine it has since you said the laptop works). To do so you need to first determine your router's inside IP address. Go to Start>>Run and type in "cmd"(no quotation marks). Now int he command prompt enter "ipconfig" (no " marks). The ip address of the router will be listed next to "Default Gateway". Open a web browser (Internet Explorer, firefox, chrome) and type in that number. Will very likely be 192.168.0.1. You will be prompted for a user name password. It is probably admin/admin, or admin/(blank). You can always google the find the default password. Now click around and look for the WAN IP address. If it shows as 0.0.0.0 try clicking the renew (or similar) button.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.