Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This issue has been driving me nuts all day... I hope someone can point me in the right direction. Here's the situation overview:

  • Nvidia videocard (Dell Dimension 9200)
  • Freshly installed Fedora 14
  • The proprietary Nvidia drivers have been installed (no Nouveau driver)
  • Window Manager is set to Compiz (with wobbly windows and everything)
  • going to System -> Preferences -> Monitors tells me I have a single screen composed of the resolution of both screens (so the monitors are already abstracted away).

The problem: the desktop behaves like a giant screen spanning the both monitors. I'd prefer the behaviour as seen on MacOS X and Windows, where both monitors are treated as a separate screen, between which content can be dragged.

The most problematic is maximizing windows: instead of blowing up to fill the currently active monitor, they blow up covering both screens with a giant window.

In my NVIDIA X Server Settings panel I have the following: - Two screens are recognized. - The configuration is "TwinView" - Setting the configuration to "Separate X Windows" results in one monitor being disabled upon restarting X, the other remaining in TwinView mode.

(please note that I have no idea what I'm doing when it comes to X, and would prefer not manually meddle with its configuration files, if it can be avoided).

Any tips?

share|improve this question
I would remove the Nvidia driver to see what happens. – ngen Feb 1 '11 at 22:40
Not an option; without the NVidia driver the GPU fan blows at 100% constantly, inciting murderous tendencies among my coworkers. – Sander Bol Feb 2 '11 at 9:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.