Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am running multiple Google Chrome instances simultaneously, each with a different profile (using --user-data-dir=MyProfileFolder). I would like one of Chrome instances (profiles) use a proxy, and the other connect directly as usual.

The problem is no matter how I try to enable a proxy in some Chrome instance, it affects all other running instances too.

If I simply use ranch -> Options -> Under the Hood -> Change proxy settings, it affexts the entire system, since it's just the general Windows proxy settings page.

If I use an extension like Proxy Switch! or Switch Proxy, once again, enabling the proxy in one instance (profile) affects all others (even though the extension is not even installed in them).

Is there a way around this?

I never had this problem in Firefox.

share|improve this question

3 Answers 3

As you found out, Chrome on Windows uses the system's proxy settings. To use a different proxy for a single instance use the --proxy-server=<host:port> argument. You can add this to the shortcut for that specific profile if you want it to be active on every run.

share|improve this answer
    
But what if I need some more sophisticated settings, such as a rule limiting the proxy to some addresses only? Is that possible? –  David B Feb 2 '11 at 7:44
    
To be honest with you, I don't know. I use Chrome only occasionally. I only found out the answer to your question via Google. My guess would be that it's not possible, but I could be wrong. –  jaquer Feb 3 '11 at 5:15

I installed this extension - proxy switchy - and it solved my problem

I also made 2 users in chrome and launch them with

C:\Users\iuri\AppData\Local\Google\Chrome\Application\chrome.exe --profile-directory="Profile 1"
C:\Users\iuri\AppData\Local\Google\Chrome\Application\chrome.exe --profile-directory="Default"

but with proxy switchy this is optional.

share|improve this answer

The --proxy-server=<host:port> is the only real alternative in Linux (Mint 15 kernel 3.8.0.26) actually, otherwise the changes are populated and shared among instances, even through Chromium and Chrome bundles. the --user-data-dir option seems ignored by both.

The easy workaround finally was to install both Chrome & Chromium. If somehow you realize they share stuff just clean properly the ~.config/google-chrome or ~.config/chromium to reset everything and use the --proxy-server=<host:port> with your favourite flavour. You can export-import later bookmarks if needed

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.