Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an exe file in my download folder that I half downloaded through utorrent (it's not piracy, a legit file from people who use bittorrent to distribute large files). I think I tried to open it while it was still sharing, that is, did not stop the upload. That actually froze my computer. When I restart in utorrent I set the file to be deleted. Unfortunately even though utorrent doesn't see that file anymore, it's still visible in my download folder.

Whenever I try to open my download folder it literally takes 10 minutes or more. It opens, but is empty and the blue progress bar needs a long time to complete.

After completion I can use the download folder normally, but opening and closing things in that folder takes a long time. I see the exe that I tried to download. I tried to delete it. But it was taking so long 30+ minutes that I eventually just hit cancel. That doesn't even work, and it was slowing down the computer. Couldn't figure out how to stop the delete so I just pulled the plug.

Should I just forget about that dl folder and set a new one? Is there something I can do?

Thanks.

share|improve this question
    
Have you defragmented to see if it helps? Or tried moving the files in that folder to another to see if the issue persists with the same folder? –  Ciaran Feb 1 '11 at 21:50
    
@ciaran the culprit is that one exe i can't delete it though. i've moved all the other files out. –  Mark Feb 1 '11 at 22:20
1  
Run a check disk, that should clean up any issues on the drive. –  Kyle Feb 2 '11 at 1:22
    
I have a freeware tool called Unlocker installed -- It lets me just right click a file and press "Unlock", and it tells me what processes have it locked and allows me to kill them or failing that allows me to schedule a file delete/rename/move/copy on reboot. -- First thing's first though, close uTorrent, run chkdsk. –  BrainSlugs83 Jul 13 at 20:59

6 Answers 6

up vote 1 down vote accepted

I would delete that folder and create a new one.

If it will not delete, use this trick:

  1. Open an elevated Command Prompt and leave it open.

  2. Close all open programs.

  3. Click Start, Run and enter TASKMGR.EXE.

  4. Go to the Processes tab and End Process on Explorer.exe. Leave Task Manager open.

  5. Go back to the Command Prompt window and navigate to the the folder (or other undeletable file) is located in. At the Command Prompt type DEL <filename> where <filename> is the file you wish to delete.

  6. Go back to Task Manager, click File, New Task and enter EXPLORER.EXE to restart the GUI shell. Close Task Manager.

  7. Run a chkdsk when this is done.

share|improve this answer

Sometime ago i have the same problem, this steps works for me.

  1. open your download folder
  2. right click in a white space and go to properties
  3. select the tab "Customize"
  4. in the dropdownlist of "Optimize this folder for:" select "General Items"
share|improve this answer
1  
This should be marked as answer (source: answers.microsoft.com/en-us/windows/forum/windows_7-files/… ) I would imagine that when recreating the folder as described in Moab's answer the folder defaults to being optimized for general items. –  joelmdev Jul 16 '13 at 0:25
1  
This has plagued me for so long. Thank you mjsr. And this really should be marked as the answer. –  kmort Sep 13 at 3:13
  1. Open Windows Explorer. On the left, right click on Libraries, select New, Library, name it "Downloads".

  2. Right click on the new Downloads library, go to Properties, select Include a folder...

  3. Locate and select the original Downloads folder from "My Computer, C:\Users\<your user profile>, find the Downloads folder, select it, click Include folder.

From now on, whenever you click on the Downloads folder, it will open instantly.

share|improve this answer

Quite late to give input on this topic but anyway here it is. This started happening to me a few weeks ago, normally I only had executable and compressed files in the downloads folder until I started downloading youtube videos, at first I didn't realize that it was around this time when the problem started. Anyway, check the customize tab of the downloads folder properties, for me it was automatically set to videos (since I started downloading them to this folder) so I reverted the "optimize this folder for" to either General Items or Documents and the problem went away.

As a general note, I try not to have too many files of different type in the same folder. Put all of your videos in My Videos, all of your pictures in My Pictures and all of your music in My Music and leave the downloads folder for non-media files.

share|improve this answer

It may be that the file is massively fragmented, as files often are through bittorrent, particularly as they get added to by multiple nearly simultaneous threads.

A couple of points to try:

(1) make sure you have enough free space on your drive. Windows bogs with full filesystems.

(2) make sure you've deleted utorrent's temp files. Try

c:\Users\{yourname}\Local Settings\Temp

and maybe the "Application Data" folder.

(3) let Windows take its time deleting that file, following the comment from Ciaran

share|improve this answer
    
I have enough free space. I looked in temp, i don't see a folder called utorrent. I'll try defragging and letting that folder be deleted. –  Mark Feb 1 '11 at 22:44

I also know this is a bit late to chime in but here is what I did to fix the program. I created a folder and added all the short cuts in and they open up just fine no issues

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.