Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Same as this question, but for OSX.

In short: how to I enter rectangular selection mode on OSX?

I see a button for doing this with the standard useless "text editor" that is default with eclipse, but not with the "javascript editor" which I use 99% of the time.

share|improve this question
add comment

3 Answers

Press Command-Option-A or click the Toggle Block Selection Mode button in the toolbar.

enter image description here


It looks different from Cocoa native block selection:

enter image description here

share|improve this answer
    
command+option+a does not work for me.. –  erikvold Jul 16 '12 at 15:53
    
also I don't see that button.. –  erikvold Jul 16 '12 at 15:53
    
@erikvold What version and variant of Eclipse are you using? –  Daniel Beck Jul 16 '12 at 18:36
    
I am using Version: 4.2.0 –  erikvold Jul 17 '12 at 16:27
    
@erikvold Cannot reproduce the problem. Did you maybe just open a perspective that does not include this in the toolbar? Do you have an editor open (only then are these text editing buttons displayed)? Have you tried to create a new workspace to see if you just messed up your configuration? Please provide more relevant information... –  Daniel Beck Jul 17 '12 at 18:20
show 4 more comments

As Daniel said press Cmd + Option + A. If the button is not showing in the toolbar you can activate it with:

  • Window->Customize perspective
  • Command Groups Availability
  • enable the Editor Presentation group.
share|improve this answer
add comment

You can hold down Option while selecting, your cursor should change into a plus sign, then you can select rectangularly. This works in nearly any application, by the way.

share|improve this answer
    
It doesn't even work in Safari multi-line form fields. The chance it works in a Java cross-platform application is even worse. –  Daniel Beck Feb 2 '11 at 8:17
    
It doesn't work in Eclipse.. –  Lipis Apr 4 '11 at 15:55
    
this doesn't work for me –  erikvold Jul 16 '12 at 15:53
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.