Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Lately I've noticed that my Firefox Browser was taking a long time when I would search Google, e.g. 3 seconds before I would see any results.

If I search for a three-word phrase, it just hangs trying to connect:

enter image description here

I removed all add-ons but it still does this.

I thought it might be something with my router, but Chrome, Safari, Opera and Internet Explorer all work fine.

Bing works fine in Firefox.

Here's my Firefox version information:

enter image description here

Otherwise I can still use Firefox, e.g. I'm using it to post this question, but I do notice that when I browse with it, images are often "broken" for a split second before they appear, as if it is having a hard time pulling them from a remote server. Other browsers don't do this.

What could be causing Firefox to hang when searching Google?

share|improve this question
    
Does it do the same thing on a different computer? –  Mehrdad Feb 2 '11 at 5:13
    
On a second computer using WLAN with the same router, Firefox works fine. –  Edward Tanguay Feb 2 '11 at 5:19
    
Huh, interesting. Have you tried clearing your history (cache, cookies, etc.) by any chance? –  Mehrdad Feb 2 '11 at 5:23
    
Ok, I did tools | clear recent history (which knocked me off this site, had to log back in) but no, search google still hangs. –  Edward Tanguay Feb 2 '11 at 5:31
    
You may have added a IP address to your firewall that inadvertantly blocks google services? Which version of Firefox, what OS, what kind of network are you behind, all this information is needed when troubleshooting such a difficult and weird question. –  palbakulich Feb 2 '11 at 5:32
show 7 more comments

1 Answer

up vote 1 down vote accepted

Try running firefox in safemode. There should be a link from when firefox installed. The target in the shortcut is the same except it just has -safe-mode at the end. I have found that malicious plugins or settings can remain even after disabling everything manually. If firefox suddenly works in firefox -safe-mode then there is a good chance that there is a plugin that is not playing nice and will need to be removed by a program like Spybot Search & Destroy , Ad-Aware, super antispyware, or malwarebytes.

Also make sure that firefox is not set up to use any proxy settings. It should be set to "Use system proxy settings" by default.

share|improve this answer
    
If it is set to "Use system proxy settings", then check IE's proxy settings. Even though Google works in IE, it is possible that malware has set a proxy for IE (and all other apps that check system proxy settings) that behaves oddly when it sees Firefox. Not likely, but a few extra clicks for something worth checking. –  TuxRug Feb 2 '11 at 6:32
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.