Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm encountering an odd problem with a new notebook we recently helped choose & buy for an elderly neighbour. The machine doesn't have a "hard" switch to turn the WiFi adapter on or off but you can toggle this using Fn+F11, and there's a status LED that turns on/off to indicate the adapter is on.

The problem we are finding is that any time the machine is restarted/shutdown/put into sleep mode, the WiFi adapter will turn off. Pressing Fn+F11 will immediately turn it back on again once the machine has booted back up into Vista, but we'd rather this wasn't necessary.

What I've already tried:

  • Going through all the settings for the network connection in Vista - nothing there about turning the adapter on/off.
  • I have checked the BIOS - no options for the wireless adapter there.
  • Power Configuration - I've told it to use "Maximum Performance" settings for the wireless.
  • I've examined the adapter's options in Device Manager - there's nothing there for power options.
  • When the adapter is turned "off", it does NOT show as disabled in Device Manager - so I'm guessing it is enabled, just powered down.

I'm at a complete loss where else these settings might be! Clearly something is handling the Fn+F11 keypress, so it seems crazy that those settings aren't configurable to keep the adapter turned on somewhere...

Few more pieces of information: the machine is from a local company called Novatech, and I think it's a Clevo notebook chassis. It's running Vista Home Premium, and the wireless adapter is a Realtek device - afraid I can't provide model numbers as I don't have it with me at the moment.

Would greatly appreciate any tips or advice!

share|improve this question
    
A Toshiba laptop I recently bought is suffering from the exact same thing! –  David Pearce Oct 13 '09 at 15:04
add comment

4 Answers

Some ideas:

  1. If you don't mind the wifi card staying on, uncheck "Allow the computer to turn off this device" in "Device Manager/$device$/ Properties/Power Management", where $device$ stands for keyboard and mouse.
    This will have a bad effect on battery life during sleep.
  2. Turn off Hybrid sleep, see explanation here. If you don't need it, this may have some negative effects regarding sleep (but read very well the explanation).
  3. Look in your BIOS for the suspend ACPI options and try to switch modes among "S1 and S3", "S3" etc. See explanation here.

Note: Any of the above manipulations that doesn't help should be undone.

share|improve this answer
add comment

You seem to have done most troubleshooting you can do on this issue.

The only thing I can suggest is to check for newer drivers for the wlan adapter.

share|improve this answer
add comment

My brother was having the same problem on his dell laptop (vista home premium). Wifi connection on that was not consistent. You have to enable and disable wifi radio using some Fn key combination. Few seconds after that Windows was looking for wireless network and trying to connect. But didn't connect successfully to any wireless connection.

  • I connected second laptop on same network. So it wasn't wireless router issue.
  • I thought there might be some error while getting ip address dynamically. So I changed wireless connection > ip address v4 to be static from dynamic. But this didn't work.
  • At last, i thought of checking if this laptop had Windows Vista SP2. Guess what It didn't. I updated the machine on wired connection. After update, wireless started to work without any issue.

Hope This helps.

share|improve this answer
add comment
up vote 0 down vote accepted

Thanks for everyone's suggestions on this - I'm sure they would have been useful in the majority of cases!

However, since my initial post we've been in touch with the manufacturer and much to my disgust this behaviour is inherent to the machine - there's no way at all to change it. Apparently this is to prevent interference when travelling by air with your laptop! I've never heard anything so ridiculous - it's not the manufacturer's responsibility to control this, it's the owners - but there you have it.

I'm answering my own question here so people might find this - it's definitely worth checking before buying a new notebook! I'm still aghast some manufacturers are doing this but certainly won't be buying a machine with this "feature" again.

share|improve this answer
    
Huh. How about that. Thanks for the update. –  Pops Oct 28 '09 at 14:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.