Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am getting following cryptic error:

akshay@akshay-VirtualBox:/mnt/mmpp$ ./bin/metamap10

/mnt/mmpp/bin/SKRrun.10 -L 2010 /mnt/mmpp/bin/metamap10.BINARY.Linux -Z 10 --debug input.txt
fopen: No such file or directory

does this error implies that it cannot fopen cannot find a required file or fopen itself is nonexistent, note that both SKRrun.10 and metamap10.BINARY.Linux are present at the correct location

I am using this software on Ubuntu.

share|improve this question
up vote 2 down vote accepted

To really know, you'd have to debug the software. However, fopen is a standard C libary function (see e.g. ), which is used to open a file for reading or writing.

The error message you see is often printed if a program invokes fopen, and the invocation fails. Properly behaved programs would also print out which file they tried to open, and what kind of failure occurred, but this program is apparently not one of those :-).

So most probably it means that the program tried opening a file, but could not (file not found / rights problem / disk on fire / whatever).

To investigate further, you could run the program using strace ( ) , this will (more or less) log all system calls a running program makes. There you can look for a call to fopen right before the error message, that should be the culprit. strace's log output will show the filename.

share|improve this answer
Thanks for the answer, it seems there was some problem in extracting the software. (For future reference: I was extracting it on non ext file system. And thus symlinks couldnt be created.) – None Feb 4 '11 at 0:57

Is your OS 64-bit or 32-bit? If you are running a 64-bit OS, the problem maybe 32-bit libraries on 64-bit system. Please refer to for more information. I use Ubuntu 64-bit. The problem was solved when following the instruction: $ apt-get install ia32-libs

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.