Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have recently purchased a new laptop from an OEM with Windows 7 64-bit. This system came pre-installed with (among other stuff) the Java Runtime Environment (64bit). This has put the "jusched.exe" (Java update scheduler) process in my start-up processes. I want to disable this however, because I want to schedule the update process myself.

Now, on my other 32-bit system, this was simply a matter of going to the Control Panel, selecting Java, clicking the 'Update' tab, and there it could be disabled. However, there is no update tab on this 64-bit version of the Java config tool.

I have been trying a number of things so far to disable jusched:

  • Running the config tool as admin: still no tab
  • remove it from the start up folder: there was no entry for jusched
  • trying to disable it from msconfig: again no entry for jusched

So, does anyone have any other suggestions (apart from uninstalling java)? Thanks!

share|improve this question
1  
Some people might have unknowingly insalled Java via OpenOffice.org –  reconx86 Mar 2 '13 at 13:29
add comment

9 Answers

up vote 17 down vote accepted

Search for it in Administrative Tools / Task Scheduler.

You can also use Autoruns and search for "java" or "jusched" for any startup of any kind. The interface makes is easy to disable anything you don't like or re-enable it again.

share|improve this answer
2  
Thanks for the advice on Autoruns. It's a very nice tool indeed, it found jusched and disabled it –  Rewinder Feb 3 '11 at 16:20
    
Now in Windows 8 one can disable it through the Task Manager. Just go to tab Startup right click on the jucheck and choose disable. I think that will do the trick. –  Devid Jan 16 at 11:21
add comment

To disable jusched.exe without installing anything, run the javacpl.exe file as administrator (right-click the file then select "Run as administrator"), usually located somewhere like :

C:\Program Files (x86)\Java\jre7\bin\javacpl.exe

Then on the Updates tab untick Check for Updates Automatically

share|improve this answer
3  
I've had my PC set like this for months, but justched.exe still pops up that obnoxious An Update is available every time I log in. –  jp2code Mar 1 '13 at 1:38
add comment

It shows up in my startup tab in msconfig, the command entry points to jusched.exe, Disable it in there as suggested by MBraedley.

enter image description here

share|improve this answer
3  
As I stated in my question; there is no entry for it in msconfig. –  Rewinder Feb 3 '11 at 16:17
1  
Making sure you did not miss it. I see you found it with Autoruns. –  Moab Feb 3 '11 at 16:49
add comment

Run msconfig.exe from the start menu search box. Click on the startup tab, and deselect anything that you don't want to run at startup. Note that upgrading your JRE will usually place a new entry in this list.

share|improve this answer
3  
As I stated in my question; there is no entry for it in msconfig. –  Rewinder Feb 3 '11 at 16:17
    
Sorry, didn't notice that. I find it really weird that it's not there, unless you installed it under a different user. –  MBraedley Feb 4 '11 at 13:53
    
\Program files*\java\..\bin\javacpl works if you only have one version of the JRE, and can find it easily. Otherwise, run msconfig and uncheck "Java Updates" from the [Startup] tab. –  paulsm4 Oct 24 '12 at 16:17
add comment

Just delete the registry entry

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run\SunJavaUpdateSched

share|improve this answer
add comment

A brute force way of preventing it would be to navigate to:

C:\Program Files (x86)\Common Files\Java

(this is where mine is on a 64 bit Win 7), then rename the directory within this, say from "Java Update" to "xJava Update".

Java still works fine, I haven't tested this does actually prevent the update but I'm pretty confident it'll break it. If this causes any problems, try renaming jusched.exe within this directory instead.

To answer: I did check the contents of the folder before posting. The update program jusched.exe is in this folder, as are jaucheck.exe, jaureg.exe and jucheck.exe. jusched.exe was in the registry as a startup item, so I assume even though my system is x64 it would have been run. This may be because I have installed 32bit and 64bit versions of Java (to run some software that demanded it) and Android development tools via an installer. Despite installing the 32bit version I do not get an update tab in the control panel with which to disable it - the 64bit cpl is run. I confirm that Java still runs fine, I've the latest version of Java so can't confirm whether updates are disabled but I'd be amazed if not - but I'm being as open and honest as possible. I am hoping I will be unaware of Oracle's next update release so unable to confirm that nothing happened when it doesn't.

(This approach, rather than deleting the registry item etc, is probably too extreme for most people, but I absolutely cannot have random large downloads as I connect exclusively through mobile networks, as that is how domestic internet works here in Ethiopia for most people. Here 100MB is a large download and liable to fail, so be repeatedly attempted.)

share|improve this answer
    
"I haven't tested this does actually prevent the update but I'm pretty confident it'll break it". Hmmm. Please come back then to report your findings? (I don't know what is inside of that folder, but unless the actual update program is in there: often tricks like this rely on having an empty folder with the original name, and then make that read-only to make sure the folder cannot be re-created, and cannot be written to.) –  Arjan Sep 2 '13 at 21:47
add comment

It should be in 'msconfig'

Type 'msconfig' in search on your start menu and open it.

go into 'services' and 'startup' and disable in both.

If it's not in msconfig use Autoruns

See video here.

share|improve this answer
add comment

http://www.ehow.com/how_12007117_disable-jucheckexe.html

Summary:

  1. Control panel
  2. Choose view small icons
  3. Click on Java
  4. Update tab

Then either (a) or (b):

  • (5a) - Uncheck "Check for updates"
  • (5b) - Update tab -> Advanced
    • Choose your desired frequency (daily, weekly, monthly)
share|improve this answer
add comment

Reference: http://www.java.com/en/download/help/java_update.xml --> paragrah 7:

Why is the Update tab missing from the Java Control Panel?

Java Auto Update is currently not available for 64-bit versions of Java. 64-bit versions of Java do not include the Update tab in the Java Control Panel.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.