Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top


When I switch on my PC, after BIOS POST, a cursor is blinking for about 5 seconds and then I am getting this error message:

A disk read error occurred.
Press Ctrl + Alt + Del to restart.

I am able to go into BIOS. But Windows loader doesn't even start. This message is shown after my motherboard logo comes and goes.


  • I DID notice my system freezing for minutes at a time for past two days.
  • Also, in the past two days, it stopped half way through the Window booting process. I had to do hard reset couple of times to get it working.
  • But since today morning, I only get this error message.


Operating System: Windows 7 Ultimate 32-bit only.
Hard disk: 1 Physical Disk - 80GB SATA
Partitions: Two (2) - C: and D:
File System: NTFS
No drive encryption or compression is turned on.

After I searched on the net, I have found people mentioning these possible causes:

  • Hard Disk is physically failing
  • Corrupt MBR
  • Bad Sector

I am planning to buy a new hard disk, install Windows on it and continue. But I need data from the old hard disk. The data I want is in D: drive, outside any Windows user folder, is not encrypted or compressed or protected in anyway. I think if someone/something can get the disk working again and knows NTFS, the data can be hopefully read.

What steps should I follow to recover files from the defective disk?


I bought a new disk, installed windows on it and added the defective one as a slave. Then I was able to read the data from the defective hard disk. Though chkdsk found lots of errors, the files I wanted were not affected and I got them back :) I am not using that hard disk anymore though it seems to be working at the moment.

share|improve this question
See this article if you want to back up your data… – Moab Feb 3 '11 at 15:41
up vote 4 down vote accepted

As you're getting a new disk to reinstall Windows you can simply plug the old disk in a slave (or put it in an enclosure and use it as an external drive). Then depending on what's actually failing you might be able to get the data off.

Taking your three cases:

  • Hard disk failing. You might be able to read data off the drive before it fails completely. This is the worst case.
  • Corrupt MBR. As you are not booting from the disk any more you should be able to use it as a second drive. But you will want to copy all the data off as it could be indicative of a more serious problem.
  • Bad Sector. Again, you should be able to read the data off the drive- apart from in the bad sector, but a repair might fix it and you can carry on using the drive.
share|improve this answer
Thanks. Can you suggest some software that you have used and works, to read data off the older drive? – user57813 Feb 3 '11 at 11:11
@Senthil - you should be able to read it with Windows - but it will depend on what's actually failing. The first thing you should do is run a chkdsk. – ChrisF Feb 3 '11 at 11:42
What do you mean by a "slave"? I haven't seen slave drives since PATA. SATA don't have slave drives. – Nelson Feb 14 '15 at 9:23
@Nelson - by "slave" I mean non boot drive. – ChrisF Feb 14 '15 at 10:46

This message is emitted by the Volume Boot Record of an NTFS volume formatted by Windows NT up to version 6.x. It isn't an MBR problem, because by the time that the error is generated, the MBR bootstrap code has successfully run, and loaded the VBR into memory and executed it.

The VBR code for NTFS generates this error message if its attempt to read sectors 1 to 16 of the volume into memory fails. That can fail for several reasons, more on volumes formatted with Windows NT version 5.1 and earlier than on volumes formatted with Windows 6.0 and later. (Some code was removed from the NTFS VBR bootstrap in Windows NT 6.0.)

The most prominent reason, after an honest-to-goodness hardware fault as mentioned in the question and in other answers, is an incorrect value in the "hidden sectors" field of the BIOS Parameter Block. This can be caused by a broken formatting program that didn't know that it is required to set this field correctly; or a broken partition management utility that didn't know that it is necessary to keep this field value in synch with the partition table for primary partitions when it moves them around.

A less probable reason still (a hardware fault being the most probable) is the use of Windows NT 6.x on a machine that doesn't support the Phoenix-Intel-Microsoft EDD firmware extensions to INT 13h. The code that was dropped from the Windows NT 6.0 VBR was the code to deal with the case that such extensions were not supported by the machine firmware. Since these extensions pre-dated the release of Windows NT 6.1 by some twelve years, it is unlikely to be the case that one is attempting to install Windows NT 6.1 on an old machine that does not have them. But the remote possibility that one is doing is another possible cause of this error message that should be mentioned for completeness.

Microsoft states that this error message will also appear when an NTFS system volume with Microsoft Boot Manager on it is incorrectly formatted with the Windows NT 5.x NTFS VBR instead of the Windows NT 6.x NTFS VBR, and provides step-by-step instructions for both restoring the correct version NTFS VBR and adding an {ntldr} option to the Microsoft Boot Manager menu to do what the older version NTFS VBR would have done directly.

share|improve this answer

It is possible that this error can show up when your hard drive is perfectly fine, with no need to replace it or reinstall an OS (though imaging to a new drive might be advisable just in case). After multiple hours grappling with this same error on a system I support (Dell Vostro 220s with Windows 7 Enterprise), this solution worked for me:

Swap out the power supply

That was it - didn't make much sense, and I only tried that after testing MANY other things. This forum on the Dell site is what finally clued me in: . I figured I'd try to save some other people the time it took me to hunt it down.

share|improve this answer

In my particular case, I simply had to rearrange my boot priorities back to where they were.

I was partitioning a disk in the management console, and I accidentally clicked on "make this partition active" on the second drive. I thought to myself - "Aw, what the heck. It's not like it's set as the boot disk, anyway..."

Apparently, Windows (I use Windows 7) was kind enough to inform the BIOS of the "update", OR the BIOS somehow updated it itself (haven't seen it before, but the BIOS has a mouse pointer and all). In any case, it actually DID get set up as the boot drive.

The solution was to revert back to the previous setting, and the problem was gone. Took me a while to figure it out as I

  1. don't remember my boot order by heart,
  2. have been replacing drives (for reasons outside the scope of this answer) on-and-off for the past few months so I don't remember my HDD IDs, and
  3. fiddled with the partitions at least a week's length prior to this failure.

It all contributed to me not connecting the dots and not seeing the problem as obvious right away.

Hope this helps someone.

share|improve this answer

I think your drive is defective, so you need to install the new drive and the SO no it. Then boot from it and read whatever you can from the other disk. Probably there are files taht can be read without problems.

share|improve this answer

This type of error occurred may be after instling critical windows auto update,broken partition management or broken formatting program

share|improve this answer
  1. Run CHKDSK /R /P from the recovery console (it will typically find no error)
  2. run FIXBOOT from recovery console (typically has no result)
  3. run FIXMBR from recovery console (typically has no result)
  4. Run the manufacturer's diagnostic utility, downloaded from their website (it will typically find no error)
  5. Changing the drives from cable select to Master/Slave may fix it.
  6. Replacing the data cable may fix it, but usually not.
  7. Setting the BIOS to use defaults may fix it, but usually not.
  8. Changing the BIOS drive settings from auto to user-specified, ensuring that LBA is selected may fix it.
  9. Pulling the CMOS battery to let the BIOS lose it settings may work.

At this point, you may be feeling some frustration. :-)

If all that fails, here's what will usually work:

Ghost your data to a new drive, and use the original one as a slave. It will work. And all of your data will still be accessible. Your computer should boot normally. If it doesn't, or it there

share|improve this answer

You must log in to answer this question.