Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am desperate, and hoping I can get help from you.

I have HP pavilion dv5000 with 3 port, running win7. Three days ago, I used a usb modem to connect to net and I powered off the computer while the usb modem still plugged in (I really can't tell if this is the cause of my problem) when going to bed.

The next day, my computer won't recognized any usb storage device. To try find out what is going on, I tried the followings:

  1. tested the pen drive on another computer and it worked fine
  2. tested the usb modem on my computer and it also worked perfectly
  3. tested a usb mouse on my computer and it worked fine without problem
  4. Formatted the hard drive twice
  5. Bought a new hard drive and performed a fresh installation
  6. some websites suggest to create DisableSelectiveSuspend in the registry and set its value to 0
  7. some other websites say leaving the computer off and unplugged would solve the problem, but no luck when I left mine off for two days without battery.

I'm now out of option, please help cause I have information on my external hard drive I need to use.

share|improve this question
    
What do you see at the device list when you plug an USB harddisk? And what do you see at the Disk Manager (under computer management)? –  SoMoS Feb 3 '11 at 10:59
    
Thanks for answering, at the device list, I can read unknown device and at the computer management, I have systems tools, storage, services and applications. –  lom se Feb 3 '11 at 11:06
    
SoMoS wants you to look into "STORAGE" and "Disk manager"... Also that's really strange, the USB controller might have a knack... –  sinni800 Feb 3 '11 at 12:15
    
@Inni800 I realized that one of the pen drives works when i plug them simultaneously. I even changed the hard drive and cd rom letters from d and e to x and y but still not luck. Thanks for answering –  lom se Feb 3 '11 at 15:15

2 Answers 2

this might seem bizarre, but fire up a linux install off a live cd, unetbootin or wubi - then mount or force mount the drive (as needed) there, and see if you can get your data off.

In some cases, windows might have issues reading the drive but linux may not.

share|improve this answer

To rule out a Windows issue try booting from a USB device using the bios, if it boots from a bootable usb drive, then it is a Windows issue, if it does not, then it is a hardware/bios issue, which may be hard to remedy.

Not all systems can boot from a USB device, some that do, need to have this feature enabled in the bios prior to booting from a USB device.

If you determine it is a windows issue, try this

Open Device manager using Control Panel (not manage), expand the USB section, right click on all the sub entries and select "uninstall", once this is done click the scan for hardware changes icon at the top of DM, this will reinstall all the usb drivers, try a known good usb device now.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.