Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to publish an InfoPath 2007 form, I get the following message:

To use this feature, Microsoft Office 2007 must be set as the default e-mail program.

However, Outlook is configured as default e-mail program already. Any ideas?

Screenshot of InfoPath Publishing Wizard

I verified that Microsoft Outlook is the default e-mail program in two ways:

  • I went to Control Panel > Internet Settings -> ... -> Default Programs
  • I tried and entered mailto:myown-e-mail-address in Firefox and it opened Outlook.
share|improve this question

I've had this same problem recently and have also looked online for solutions, without much success. Here are a few ones worth considering:

  • Run repair on your Office 2007 (instructions can be found here)
  • Verify that Outlook is really your default mail client. To do this, go to Control Panel > Network and Internet > Internet Options > Manage browser add-ons > Programs> Internet Programs.
  • If all else fails, try closing Outlook when sending your forms in InfoPath.
share|improve this answer
    
Thanks, Melissa. I did verify that Outlook is the default (updated my question). I will try the "close Outlook" trick and the repair-office approach and see whether it helps. (I'll not be able to do that before March though...) – chiccodoro Feb 4 '11 at 17:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .