Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have problems with my USB driver. After adding my device (MSP430 USB-DEBUG-INTERFACE) it doesn't work.

[   60.476039] usb 2-2.1: new full speed USB device using uhci_hcd and address 8
[   60.693959] ti_usb_3410_5052 2-2.1:1.0: TI USB 3410 1 port adapter converter detected
[   60.693981] ti_usb_3410_5052: probe of 2-2.1:1.0 failed with error -5

I try to do:

modprobe ti_usb_3410_5052

No changes.

It's Linux

Linux ubuntu 2.6.35-25-generic #44-Ubuntu SMP Fri Jan 21 17:40:44 UTC 2011 x86_64 GNU/Linux

I hope someone can help me.

share|improve this question
    
I believe you need to check out the sources and look into probe function to see what the hell -5 actually means. –  Andrejs Cainikovs Feb 3 '11 at 15:07
add comment

1 Answer 1

Most likely you faced a known issue when firmware file is expected to have a new name.
This should help:

sudo cp /lib/firmware/$(uname -r)/ti_3410.fw /lib/firmware/ti_usb-3410.bin
share|improve this answer
    
I still get the same error. –  alschbpk Feb 3 '11 at 15:39
    
Please provide full log. –  Andrejs Cainikovs Feb 4 '11 at 11:21
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.