Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I did some brain-dead reconfiguring of my D-Link DNS-323 NAS some days ago. I have a home network where each computer gets a dynamically allocated IP address starting at 192.168.1.100.

The irritating point (for me at least) was that the NAS changed IP if the power went down or I turned off the router. I then had to remap a drive-letter to point to the new IP address of the NAS.

To remedy that I configured the NAS to have a static IP, 192.168.0.10. I had no good reason to choose that IP, other than I found it in a user manual for the NAS.

After I changed the IP and rebooted the NAS it disappeared from the network and was never to be found again.

Now I have a black brick standing in my home, looking good, but "dead".

Could anyone point me in a direction which helps me solve this problem? I have about 100gb worth of pic of my children on this brick so I really want it back :-)

Sincerely,

share|improve this question
add comment

6 Answers

I guess your PC's are still in the 192.168.1.* range, while your NAS is now in the 192.168.0.* range. So it's normal they don't see each other.
Try giving one of your PC's also a static IP address in the same range (192.168.0.100 for instance). Then you should see your NAS again.

share|improve this answer
add comment

Looks like you need to reset your NAS to factory defaults. The reset button should be here:

alt text

This should not erase your data. In the future, if your NAS gets a dynamically allocated IP, changing settings on your NAS may not be the best route. Try assigning an IP on your router instead.

share|improve this answer
    
I checked with the usermanual and found this: "After resetting the unit’s configuration you will still have access to the data on your hard drives." In other words, your tip would have solved the problem. –  Jo Erik Aug 18 '09 at 11:01
    
makes sense. I was hoping to give you the 'least effort' answer. Since your data is stored on the swappable hard drives of the NAS, changes to the NAS shouldn't affect your data. –  jweede Aug 18 '09 at 11:58
add comment

Double check that the IP address of the NAS has been set to 192.168.0.10 by accessing your router and viewing the attached devices (without knowing the make/model of your router I can't say if this is possible but I assume it is). You should also try pinging 192.168.0.10.

 ping 192.168.0.10 

As fretje has suggested you could also move a machine into the 192.168.0.* address range and see if that works.

share|improve this answer
    
I have a Linksys WRT54G wireless router. The NAS wasn't listed in the attached devices list on the router. –  Jo Erik Aug 18 '09 at 11:03
add comment

Glad you were able to find and get your NAS back on the network! However, if you keep you NAS on dynamic, you'll still have the same problem that led you to change the ip on you NAS. If you're still looking for an answer that problem there are two things you can do:

  1. Does your NAS have a hostname? If it does you can use that to set up your networked drives instead of the ip. In windows you would get to it by: \\NASHOSTNAME\FolderName\ instead of \\192.168.1.1xx\FolderName\
  2. Set a static DHCP entry. Some routers will let you set a static DHCP entry, that is it will always assign the same IP to a specific MAC address. This way you can leave the NAS to be dynamic, but never have it change IP addresses.
share|improve this answer
    
I went for solution 1. It works like a charm! Thanks! –  Jo Erik Aug 18 '09 at 15:09
add comment
up vote 1 down vote accepted

I didn't dare to reset the NAS because I wasn't sure I wouldn't lose the data on it.

Pinging it didn't produce any result either so I was about to change the IP on my laptop so it would be on the same network and try that route.

But before that I tried one last thing, (which I have tried before without any luck): the easy_search utility that D-Link supplies with the NAS.

The "Easy Search" utility found the NAS this time, and even let me change the NAS' configuration back to a dynamic IP, rather than static.

Thanks for helping me out guys! I was stuck, and without any tips from you I wouldn't have tried the easysearch utility since it didn't work the last time :-)

Sincerely, Beles

share|improve this answer
    
You should select this answer as the correct answer (click the check) later on; can't remember how long you have to wait. –  hyperslug Aug 18 '09 at 11:03
    
2 days I think –  fretje Aug 18 '09 at 11:58
    
You have to wait 48 Hours, I believe. –  jweede Aug 18 '09 at 11:59
add comment

Turned out when I burnt out my old router, and replaced with a new one, I'd forgotten the NAS (WD Worldbook) was set to a fixed ip, on a different subnet. So I couldn't find it. Path to rectification was to use the reset/recovery button. It doesn't wipe data, only the settings on the device. Poof! it worked again.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.