Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am using Windows 7 with one of the Administrators accounts. I cannot open and delete a file in theProgramData\Micrsoft\Crypto\RSA\MachineKey folder. But I can add a new file into it. I tried to open a console window by "Run as Administrator" and navigate there. But it still did not allow me to do open and delete.

Is there a way to open an existing key file or delete an existing key file there?

EDIT:

I mean by hand not from a running program.

share|improve this question

migrated from stackoverflow.com Feb 4 '11 at 11:37

This question came from our site for professional and enthusiast programmers.

    
You could boot from an Ubuntu CD, delete it that way. –  Moab Feb 4 '11 at 15:46

1 Answer 1

  1. Go to Control Panel, Folder options, View and uncheck "Display simple folder view..."
  2. In Explorer go to ProgramData\Micrsoft\Crypto\RSA folder, press right mouse button on MachineKey folder and choose "Properties", then "Security"
  3. In window "Group or user names" choose your user name, in "Permission for..." check "Full Control", press "Apply", then press "Advanced"
  4. In "Permission" section uncheck "Inherit from parent..." and check "Replace permission...", press "Apply"
  5. In "Auditing" section add (if does not exist) your user name, check "Full Control", then uncheck "Inherit from parent..." and check "Replace permission...", press "Apply"
  6. In "Owner" section add your user name, check "Replace owner...", then press "Apply", press "Ok"
  7. Press "Ok"
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.