Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I'm specifying an argument for make like PREFIX_PATH=/some/path/to/prefix/ I sometimes experience very slow completion for my directories (a few seconds). It's annoying when I've got several variables to specify.

To get around the problem I've been typing out the variables first to get regular completion speed, then hitting Home to insert make at the start of my command line. What is happening and how can I fix it?

share|improve this question
    
NFS or Samba filesystem? Or maybe it's bash-completion? Try disabling it if that's used. –  maxelost Feb 4 '11 at 15:20
    
It's and NFS filesystem. The problem is really noticeable when the server and network are loaded. What I don't understand is why the completion is bad when it's completing for a make arg, but is fine when completing for a shell variable. –  Andrew Wood Feb 4 '11 at 15:31
    
I'm also not sure how how to disable what you're talking about. –  Andrew Wood Feb 4 '11 at 15:32
    
You need to address a comment poster like this: @maxelost or they might never see the reply. –  Dennis Williamson Feb 4 '11 at 15:58
    
@ajwood: if you use bash-completion (it's a package addition to bash), then try to figure out how to disable it (e.g. look at /usr/share/doc/bash-completion/README.gz), and see if it helps. –  maxelost Feb 4 '11 at 16:33
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.