Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I created a lamp (Linux Apache Mysql PHP) installation on a home computer. I downloaded a package known as ilias and extracted it in document root as

/var/www/ilias

now when ever I try to install it as per instructions http:///ilias/

I see the directory ilias getting downloaded as a bundle of zip files on my local machine.

How ever when I go the computer where it is actually installed and there I do http://localhost/ilias

then I can see the installation screen.

I am not able to understand why is this happening. Following is my vhost configuration

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        ServerName localhost
        DocumentRoot /var/www/
        <Directory /var/www/>
        Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all

        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined


</VirtualHost>
~                

Here is apache log when I access the site on machine where it actually is as hxxp://localhost

127.0.0.1 - - [04/Feb/2011:22:18:29 +0530] "GET /ilias/templates/default/images/ButtonsBack.gif HTTP/1.1" 304 - "http://localhost/ilias/templates/default/delos.css" "Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.8) Gecko/2009033100 Ubuntu/9.04 (jaunty) Firefox/3.0.8"

but when I do http://192.168.43.129/ilias/

I do not see any entry in /var/log/apache2/access.log . The most surprising part of this problem is I have installed Ubuntu in a Vmware running on a Laptop. The IP of Guest Ubuntu is 192.168.43.129 and that of host Ubuntu is 192.168.1.3

share|improve this question
    
Are you sure you should be typing hxxp? Shouldn't it be http? –  mickburkejnr Feb 4 '11 at 17:13
1  
Due to spam filter policy to put my post on this forum I can not give more than 2 urls when I put my question with http then the forum's spam filter do not allow me to post so I have to put hxxp instead of http. –  Bond Feb 4 '11 at 17:58
add comment

1 Answer

Ok I got a solution to above problem

<VirtualHost *:80>
        ServerAdmin webmaster@localhost
        ServerName localhost
        DocumentRoot /var/www
#Remove the 4 lines below had created problem that site started getting downloaded
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride All
                Order allow,deny
                allow from all
        </Directory>



        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined


</VirtualHost>

This configuration worked.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.