Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I upgraded RAM on my old Asus M2N-E SLI today and sound does this hiccuping, sometimes distorted sound when I run some video or game.

Old RAMs were 3x 1GB DDR2 memory stick at 667MHz (non identical manufacturers). New ones are 3x 2GB DDR2 sticks at 800MHz (all of them Kingston).

After I try to put old ones in, it does the same. As if new ones messed up the motherboard. BIOS is updated. Got the newest drivers and DirectX.

Any idea what might be causing it?

share|improve this question
    
Are you using onboard audio? I had a similar problem with >2GB RAM and an old Soundblaster card... –  Mokubai Feb 4 '11 at 18:19
    
Sound is onboard. –  Ondrej Slinták Feb 4 '11 at 18:23
    
did you discover the solution? –  kokbira Apr 12 '11 at 20:56
    
Yes, some capacitors were probably burned. –  Ondrej Slinták Apr 13 '11 at 16:38

3 Answers 3

up vote 2 down vote accepted

I have some sound problems with my motherboard (another manufacturer) and I think it can be solved with a bios update (but I cannot found it yet, so I've not done it). These problems was introduced with me Windows 7 installation. I also have Windows XP in my computer just to play games without sound distortion...

But in your case I think you have exploded some capacitors in your motherboard :) because you said that the problem occurs also with your old RAM chips...

Well, search more on Internet. Try to see all capacitors in your motherboard too... http://www.google.com/search?q=Asus+M2N-E+SLI+sound+problem&ie=utf-8&oe=utf-8&aq=t

share|improve this answer

Check all of the connections to the motherboard, you may have disturbed something

share|improve this answer
1  
Especially the sound card (remove it and then reseat it), provided it is not built into to motherboard –  horatio Feb 4 '11 at 18:06

In XP go to Control Panel... Performance and Maintenance... System... Hardware...Device Manager...

Click on the IDE ATA/ATAPI Controllers to see a list of your Primary and Secondary Channels. Right click on each and select Properties... Under the Advanced Settings check to see if the Transfer mode is set to DMA if available and that the Current Transfer Mode is NOT PIO. If it is PIO Right click the drive channel in the device list and click Uninstall! This might seem a LITTLE RADICAL, but it will fix the problem.

After you have uninstalled the drive channel, Windows will want to Restart your computer. During that time, it will reset to a DMA setting in most cases. If it does not, then you are stuck with PIO.

I think that my DMA problem was created when I installed a second hard drive. Oddly the Primary was PIO and the newer drive was already set to DMA.

Give it a try! It worked wonders for my sound and the darn thing runs a little faster too!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.