Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been trying to dual-boot FreeBSD 8.1 with Mac OS X on my MacBook (5,2), but am having trouble trying to get the live cd to boot.

I reach the FreeBSD Boot Loader Screen with the options for boot, boot without ACPI etc.

However, I cannot select an option. I have tried with both the built in keyboard and a USB keyboard, but I do not think that that is the problem...

Previously I have tried dual booting Ubuntu, but had problems with the live CD also. During the boot process, the boot seemed to freeze, and the CD stopped spinning. I think it might be a similiar problem here. Soon after arriving at this screen, the CD stops spinning.

Thanks for any advice!

I've tried using both the amd64 disc1 iso image and the i386 disc1 image for FreeBSD 8.1

Further Boot Info

When booting, Mac's EFI allows me to choose to boot from the CD. The screen goes black, then the following appears:

CD Loader 1.2
Building the boot loader arguments
Looking up /BOOT/LOADER ... Found
Relocating the loader and the BTX
Starting the BTX Loader

BTX Loader 1.00 BTX version is 1.0.2
Consoles: internal video/keyboard
BIOS CD is cd0
BIOS drive C: is disk0
BIOS 639kB/1047552kB available memory

Loading /boot/defaults/loader.conf
/boot/kernel/kernel text=0x8d5503 data=0x129bf8+039f8 syms=[0x8 + 0xddbf8 + 0x8 + 0xca37e]

It then continues to the FreeBSD Boot Loader Screen, and freezes

Update

Having tried both the amd64 and the i386 versions of FreeBSD 8.1, I've tried using the i386 version of FreeBSD 8.2.

It acts exactly the same as previous attempts, except that instead of freezing at the FreeBSD Boot Loader Screen (linked above), it prints some information to the screen as follows (below the boot loader screen, as it doesn't clear it first):

Copyright (c) 1992-2011 The FreeBSD Project
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
    The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of the FreeBSD Foundation.
FreeBSD 8.2-RELEASE#0: Fri Feb 18 02:24:46 UTC 2011
    root@almeida.cse.buffalo.edu.au:/usr/obj/usr/src/GENERIC i386
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Core(™)2 Duo CPU  P7350 @ 2.00GHz (1990.43-MHz 686-class CPU)

    Origin = "GenuineIntel" Id = 0x1067a Family = 6 Model = 17 Stepping = 10
    Features=0xbfebfbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,PSE36,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,™,PBE>
    Features2=0x408e3bd<SSE3,DTES64,MON,DS_CPL,VMX,EST,TM2,SSSE3,CX16,xTPR,PDCM,SSE4.1,XSAVE>
    AMD Features=0x20100000<NX,LM>
    AMD Features2=0x1<LAHF>
    TSC: P-state invariant
real memory = 2147483648 (2048 MB)
avail memory = 1789763584 (1706 MB)
ACPI APIC Table: <APPLE Apple00>
AP #1 (PHY# 1) failed!
panic y/n? [y]

Then it freezes, I cannot even enter y/n.

Again, thanks for any help.

share|improve this question

1 Answer 1

Have you tried booting with a disabled APIC? From:

http://keramida.wordpress.com/2007/12/10/disabling-apic-on-freebsd/

Stop the boot process at the boot-loader prompt, “OK”. At the loader prompt, type:

set hint.apic.0.disabled="1"

Boot in “verbose” mode:

boot -v
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.