Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to convert a mp4 file into flv with 2 audio channels & sample rate of 44.1 Khz (because .flv does not allow higher than that). Here is the pastebin for the error. As seen from the console output, I am using the latst build of ffmpeg.

share|improve this question

migrated from stackoverflow.com Feb 5 '11 at 5:59

This question came from our site for professional and enthusiast programmers.

The problem is you are resampling. Ffmpeg doesn't support resampling for 5+1 input channels, only for mono and stereo. Try converting it without specifying a sample rate and it might work. So try omitting the sample rate, that way the audio won't be resampled. Alternatively you might try just copying the audio stream (use -vcodec copy). Again the audio won't be resampled. You might also try first converting it to 2 channels intermediate file, and then resampling, but I'm not sure if this will work.

share|improve this answer
    
Ok. I think the problem if I dont mention any sample rate is that flv supports only 3 audio sample rates, 44.1 Khx being the highest. If I dont mention it might cause an error on unsupported sampling rate. – Chantz Feb 9 '11 at 15:46
    
Actually I just checked it out and gave the error when I did not specify any sampling rate. Here is the error > pastebin.com/8n2Eavt7 – Chantz Feb 9 '11 at 15:48
1  
See this link: muzso.hu/2009/02/25/…. I haven't tried it so I don't know if it really works, but it might help you. – sashoalm Feb 9 '11 at 17:25

I had the same issue when I've installed ffmpeg from RPM, but then I took the lates version from here and it worked like a charm!

One note though, some flags have been changed, for example -sameq should be -qscale 0 when using the new version, so keep in mind that it needs to be tested well before using it on production environments.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .