Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I like to create between 3 and 5 toolbars ( like the Quick launch toolbar) to house different sets of icons for daily use.

Games Office, Apps, Utils (stuff like that)

I like to right-align some of these so that all content is hidden and the chevrons (») appear. I then proceed to use each as a popup menu.

This works great, but as soon as I lock the toolbars, everything adjusts and looks horrible

Is there a way to account for this adjustment?

share|improve this question
up vote 7 down vote accepted

Instead of changing your resolution, you can also hide the icons in your system tray and/or your clock, shift all of your toolbars to the right, lock, then re-show your icons/clock.

share|improve this answer

As long as you don't reposition toolbars after they've been added you should be OK. As soon as you reposition one however, you're stuffed.

Try adding them with the taskbar already locked to avoid accidentally moving them.

share|improve this answer
Usually what I do is lock the taskbar first, then add them. If they get messed up, I remove them all and re-add. – The How-To Geek Aug 18 '09 at 4:40
The problem is that I want the right-aligned and they are left-aligned by default. – Rory Becker Aug 18 '09 at 10:50

I had the same problem with the alignment of the toolbar next to another toolbar showing a little piece of the first icon in the list.

To get rid of it, open the folder where the shortcuts are stored, cut-paste them somewhere else. resize the toolbar, lock it and then copy the shortcuts back to the folder.

share|improve this answer

The problem is that when you right align a toolbar in Windows 7 and then lock it it will still show part of the first icon. The rest of the icons will only appear in the >> menu, which is the desired effect.

Not sure why it happens, but I have found that the only way to get them sized correctly so that all the icons are hidden is to increase your monitor's resolution to a higher setting (must be wider than your standard viewing resolution), unlock the taskbar and configure your toolbars how you want them, lock the taskbar, and then change back to a lower resolution. You should only need to do this once after adding a new folder/toolbar.

There probably is a setting somewhere in the registry that could be used to change the toolbar widths manually, but the above workaround should also work.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .