Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

The application was developed (elsewhere) in Visual FoxPro 7 and 9. It runs locally, but accesses data on the server for some operations; when it does this, there are huge delays if the application is running in Windows 7, but not if it's running in XP Mode on the same machine. Any ideas? The developers are stumped.

share|improve this question
up vote 1 down vote accepted

That's possible for many reasons.

Firstly, on XP you have less traffic-intensive services running, for example you have IPv4 on XP, while IPv4/6 on Windows 7. Another may be Homegroup polling on Windows 7.

The likely reason, though, is better driver support for your NIC on XP.

Or this could rather be too much support in the Windows 7 driver. I would check the Windows 7 NIC and maybe try to disable "Large Send Offload" and/or "Checksum Offloading", if they apply.

You could also disable ipv6 in Windows 7 if you don't need it.

share|improve this answer
All good suggestions. I've tried most of them: the host is not running IPv6, Homegroup is disabled, and the NIC is configured to disable all offloading. I've checked for newer NIC drivers and found nothing. It does look like a networking issue, though. It's just odd that the host is so much slower, but then again I suppose the guest is basically bypassing networking on the host. So it's not as weird as if hard drive access was faster in the guest. – boot13 Feb 5 '11 at 17:58
I hope you looked for a driver on the website of the NIC's manufacturer. If this NIC's performance is better in Vista, you could "downgrade" to that driver in Windows 7. The last resort is to try another NIC, maybe better-supported under Win7. – harrymc Feb 5 '11 at 18:26
@harrymc: (red-faced) I think I checked the the NIC manufacturer's site, but I will do so again to be sure. Thanks for the reminder. As for the 6 Easy Ways, I've done 1, 3, 5 and 6 with no luck and will try the others. And again, thanks! – boot13 Feb 6 '11 at 22:11
@harrymc: There was a newer drive from RealTek; I tried it and it made no difference. I noticed that installing a new driver resets all the NIC settings to their default, so changed those again. Tried all the other suggestions in that article; no luck. I'm starting to think it's a FoxPro issue or just something being done dumbly (is that a word?) in the code. Now, if I had access to the source code... – boot13 Feb 7 '11 at 19:39

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.