Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to establish a USB connection between my computer and my Android device; I've downloaded the SDK and what I believe to be the proper Samsung USB drivers. I had adb working and I rooted my phone. But during the process I had to keep reinstalling the USB drivers to get it to work; Windows keeps trying to install its own drivers and now I can't install any Samsung drivers. I tried using USBdeview, but it doesn't work. How do I properly install the Samsung drivers again or stop Windows from causing problems?

share|improve this question
    
Windows 7 64-bit ? –  Sathya Feb 5 '11 at 19:02

1 Answer 1

1) Make sure that your Samsung android device is in USB debugging mode. You can turn it on or off through Settings > Applications > Development. Turning this on and off is sometimes all you need (especially if you got it to work before.)

2) Depends on what device you have. I have a Galaxy S and I've worked it. For other devices, I'm not so sure, but the protocol should be the same.

3) Download Samsung Kies (http://www.soft-files.com/samsung-kies_78273.html) It's not great (far from it), but it should eliminate the "Windows is unable to find a MTP USB device driver" problem as it will authenticate the device. To check you can always go to the command line and check 'adb devices' (assuming you have 'android device bridge' installed.)

4) Just download the drivers themselves. This worked for me. Also depends on what OS you're sporting. I've heard that Windows 7 x64 doesn't work too good with Kies. MTP USB driver issues seem to be current with 64 bits OS. I don't have x64 so I haven't tried it.

For Windows 7
For Windows 7 x64

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.