Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've installed cmus (http://cmus.sourceforge.net/) both via the source code and dependencies, compiled myself, and via Homebrew (https://github.com/mxcl/homebrew) standard install (it installs all the dependencies as well). Both versions have had the same problem: whenever anything is plugged into the output jack (say, as I'm switching from headphones to speakers), the music stops. cmus is still playing, but no sound comes out until I "set output_plugin:ao" manually again. Annoying. Anyone know why this is?

share|improve this question

According to the cmus man page, ~/.cmus/rc is where you want to put your own options, as it's read immediately after ~/.cmus/autosave.

To append the option:

$ echo "set output_plugin=ao" >> ~/.cmus/rc
share|improve this answer

This is an old one, but it helped solve my problem.

In my case I have soundflower installed. I incidentally got some sound in my headphones by a combination of plug/unplug, however the sound level was not adjustable, it ignored the system sound settings, except it muted when the system sound was set to mute.

To fix the issue:

  1. Go to Sound section in System Preferences.
  2. Plug in your headphones. The output in the Sound preferences should be changed. If the new selection is any of the Soundflower outputs, select Headphones.
  3. In cmus, run :set set output_plugin=ao

Now I can plug/unplug headphones, restart cmus, sound output properly delivered. Hope that helps

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.