Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two computers, let's call them A and B. I am sharing a folder on computer B and while the windows firewall is disabled, I can access it without any problems. However, when I enable the windows firewall on computer B I can't access the shared folder anymore. I am using the public network profile on computer B, however I enabled "File and Printer sharing" in the network center. I have no idea what I'm doing wrong, also I have problems on "debugging", the windows firewall seems not to be very verbose.

In case this maybe makes a difference, both computers are on different networks.

share|improve this question
add comment

2 Answers

Have you added an exception for file and printer sharing on both types of networks in the firewall?

Go to the control panel, click on System and Security, then on "Allow a program through Windows Firewall". Click "Change Settings", then scroll down to "File and Printer Sharing" and make sure it is checked for both Home/Work and Public networks. Click OK, and see if the file sharing now works.

windows firewall exceptions

share|improve this answer
    
hello nhinkle, thanks for your reply. I checked this and for the public network profile it was already set (and that's the profile I am using at the moment). I am wondering if windows maybe only allows shared folders on the same network. –  stefan.at.wpf Feb 6 '11 at 18:53
    
Can you elaborate on what you mean by "on different networks"? How are you sharing across different networks? I find it odd that it does work when the firewall is disabled, as that should be the only necessary exception to add. –  nhinkle Feb 6 '11 at 18:55
    
If I don't mix things up, then I mean different subnets (192.168.1.5 for A and 192.168.*2*.5 for B). Anyways, this was the problem, I'll post the solution in an extra reply in a few seconds. Thanks for your attempt to help! –  stefan.at.wpf Feb 6 '11 at 18:59
    
I now added the solution. –  stefan.at.wpf Feb 6 '11 at 19:03
    
Thanks for the update; glad you figured it out. Don't forget to mark your answer as accepted! Also, it's always nice to give helpful answers an upvote, even if they aren't your final solution. ;) –  nhinkle Feb 6 '11 at 19:05
show 3 more comments
up vote 1 down vote accepted

Ok, here's the solution: Go to the advanced settings of the windows firewall, choose incoming rules, then look for the rule "File and printer sharing (SMB incoming)" (or similar to that, I am not running an english windows version). Double click it and go to "area" (I guess this will be really translated different, just look for the a tab where you can set local and remote ip addresses for the rule). You will note, that the remote ip address is limited to the local subnet - change it to whatever you need.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.