Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

This question already has an answer here:

My account in Windows 7 is an administrator account. When I open the Run box (WinKey + R), I am warned, "This task will be created with administrative privileges."

enter image description here

Is there any way to run programs as myself, but without administrative privileges when logged in as an administrator?

share|improve this question

marked as duplicate by slhck May 24 '13 at 10:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    

4 Answers 4

up vote 1 down vote accepted

While one could argue you're doing things somewhat backwards, if you insist, you could look at:

DropMyRights

Process Explorer/Psexec

share|improve this answer
    
Note that while using DropMyRights or related software for browsers and other high-risk applications will certainly add to the security, it is nowhere near a proper alternative for the only actual solution, fully subscribing to William Hilsum's use of the exclamation mark: turn UAC back on! –  Marcks Thomas Nov 25 '12 at 18:56

Yes.

Turn UAC back on!

Technically, the program will still run under the context of your account, but UAC will prevent system wide changes without authentication first.

The only other option is to create shortcuts and then right click, and choose Run as different user then choose an account which does not have administration rights. enter image description here

share|improve this answer
    
In general, I prefer UAC to be off, since I do a ton of development work where UAC would get in the way. But a web browser, for example, I would want to run unprivileged, to minimize the risk of getting hit by browser exploits. –  kpozin Feb 8 '11 at 14:45
3  
UAC shouldn't get in the way of development if done correctly.... What sort of problems do you actually have? (Only problems I have is during setup/patching) –  William Hilsum Feb 8 '11 at 15:08

You need to turn on User Account Control:

  1. Go to Control Panel ⇨ User Accounts and Family Safety ⇨ User Accounts
  2. Click on Change User Account Control settings
  3. Select the Default level
  4. click [OK]
  5. Reboot
share|improve this answer

runas /trustlevel:0x20000 cmd.exe will e.g. launch a command prompt that believes it's an admin (if originally launched as such) but does not have elevated privileges like writing to C:\Windows\. This even works for installing e.g. msi packages that only require elevated privileges since by default they want to install to C:\Program Files (plus minus (x86)). Source: this SU answer

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.