Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am working on Vmware -ubuntu as a part of windows application. When I try to open a website on obuntu, it doenot work.

kit@ubuntu:~$ ifconfig
       Link encap:Local Loopback  
          collisions:0 txqueuelen:0 
          RX bytes:519368 (519.3 KB)  TX bytes:519368 (519.3 KB)

Whats the problem and how would I rectify it?

share|improve this question

migrated from stackoverflow.com Feb 8 '11 at 1:57

This question came from our site for professional and enthusiast programmers.

4 Answers 4

you need to change the network settings on the virtual machine from the virtual box control/startup panel. have an adapter set to NAT, and another adapter set to 'bridged' and use the name of your wireless card (on the windows box). so you will have two network adapters, probably en0 and en1 or eth0 and eth1 maybe.

share|improve this answer

If you only see one network adapter, you need to install another adapter in the virtual instance. Loopback is always there by default. Power off the instance and add an additional adapter in the network settings. If you want the instance to get it's own IP address on the LAN, set it to bridged. If you want the instance to appear as your host adapter on the network, or if you are using wireless, set it to NAT.

share|improve this answer

If that's the only network adapter that's listed, then it isn't recognizing your network adapter.

share|improve this answer
    
yes...how can I correct it?? –  Anonymous Feb 8 '11 at 1:30

Try

ifconfig eth0 up
ifconfig eth1 up
ifconfig wan0 up

If i run

ifconfig eth0 down

I do not see any of them when I simply run ifconfig

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.