Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Until sometime in early December, I had a wonderfully functioning XP-64 system. It was configured to auto download/install MS patches. I occassionally update the software on it, e.g. Open Office, Adobe Reader, Skype, but I don't fetch hundreds of tools or anything much beyond what I just mentioned.

In December, suddenly my audio stopped, and drive letters assigned to various mount points on other machines quit being available. Apparantly, the services that support these (and some others) are now not starting up when I boot/login. There isn't anything obvious in the event log. If I manually restart the associated services, these facilities come back on line and work for awhile (a day) but pretty soon the problem reappears. I don't reboot very often, nor do I log out out much.

Hints?

EDIT: July 3, 2011: No responses in 6 months. Behavior still exists. How do I track the service dependencies to figure out what service didn't start, on which these seem to depend?

EDIT: July 5: Application event log just after a boot shows the following events, in oldest to newest order:

Information: Event ID 4625: The EventSystem sub system is suppressing duplicate event log entries for a duration of 86400 seconds. The suppression timeout can be controlled by a REG_DWORD value named SuppressDuplicateDuration under the following registry key: HKLM\Software\Microsoft\EventSystem\EventLog.

Information: Event ID 1807: The description for Event ID ( 1807 ) in Source ( SecurityCenter ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: .

Error: Event ID 1030: Windows cannot query for the list of Group Policy objects. Check the event log for possible messages previously logged by the policy engine that describes the reason for this.

Error: Event ID 4096: An unhandled win32 exception occurred in svchost.exe [888]. Just-In-Time debugging this exception failed with the following error: Debugger could not be started because no user is logged on.

Information: Event ID 4625: The EventSystem sub system is suppressing duplicate event log entries for a duration of 86400 seconds. The suppression timeout can be controlled by a REG_DWORD value named SuppressDuplicateDuration under the following registry key: HKLM\Software\Microsoft\EventSystem\EventLog.

Error: Event ID 24: Event provider attempted to register query "select * from _InstanceOperationEvent" whose target class "_InstanceOperationEvent" does not exist. The query will be ignored....

====
In the system log just after the same boot:

A set of Information entries saying various services starting up, then:

Error: Event ID 7031: The Application Experience Lookup Service service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 60000 milliseconds: Restart the service.

Error: Event ID 7034: The Windows Audio service terminated unexpectedly. It has done this 1 time(s).

So, there's my problem. But why does it stop? Gotta admire the incredible amount of detail in the log message. "It stopped, duh...". (I used to build OSes, this is a crime of an error message).

EDIT 7/6/2011: I set the Service for Windows Audio to "restart on 1st error", and rebooted. Amazing, I have Audio service running now. Only one sample so I'm not sure this is the cure, but it suggests some kind of initialization bug in the Audio service.

EDIT 7/9/2011: Well, that didn't last long. The audio service went away after some 24 hours (no reboot or logout). There's the more desperate, "restart on any error" option, which I may try, but this feels like applying cardiac paddles to a dead rat to revive it.

share|improve this question
    
I have a sneaky idea: Go to Start -> Run... -> Type msconfig -> hit Enter Tell me what's there. –  evan.bovie Jul 5 '11 at 1:18
    
@emb1995: well, it was in Windows/PCHealth/Helpctr/Binaries ... looks like a sort of helpful tool. I found Services tab, which tells me Windows Audio is stopped (no surprise, that's why we're here). What were you expecting me to find? –  Ira Baxter Jul 5 '11 at 23:04
    
I was wondering if the the startup selection was set to normal startup. –  evan.bovie Jul 6 '11 at 0:11
    
@Ira: Do you happen to know about Process Monitor? –  Mehrdad Jul 6 '11 at 0:25
    
@emb1995: Yes, it was set to normal startup. –  Ira Baxter Jul 6 '11 at 3:11

1 Answer 1

up vote 1 down vote accepted
+50

Look into the history page of Windows Update. If any updates were installed around the time that this happened, you could uninstall them temporarily.

Six months afterward, it would be hard to do system restore to the state where everything worked correctly, but look into it anyway.

For the audio part, look into finding a newer driver for your sound device, maybe from the manufacturer's site, but also in the optional updates part of Windows Update.

I hope that you are on SP3 and that you have an XP SP3 installation CD/DVD. If you do, you can verify your system via sfc /scannow. If you don't, and you can't get one from the manufacturer of your computer, you can fabricate one via Slipstream Service Pack 3 into Your Windows XP Installation CD. The last resort is to look for XP SP3 as a torrent.

The next step in ascending order of desperation, is to Perform a Windows XP Repair Install. This will refresh your XP installation, without requiring the reinstallation of all your applications. Again, an XP SP3 installation CD/DVD is required.

If all else fails, reinstall XP from scratch. In this case, reformat the hard disk using the slow method that takes hours, so that all disk sectors are over-written and refreshed.

In a completely different direction, this could also be a hardware failure. If your computer is old (more than 5 years), it might be time for an early Christmas. I would suggest first to run some hardware tests to the best of your ability. Look into Best Free Hard Drive Health Monitoring & Diagnostic Programs and Best Free Memory Testing Utility.

share|improve this answer
    
Machine is high-end I7, about 1.5 years old (it was an early Christmas). I'll chase down an SP3 DVD. –  Ira Baxter Jul 5 '11 at 23:39
    
Seems there is no SP3 for 64 bit W2K. Next idea? –  Ira Baxter Jul 6 '11 at 16:08
    
W2K ? Didn't you specify XP in the post ? –  harrymc Jul 6 '11 at 17:41
    
Ooops, sorry, yes, I have XP-64. Apparantly no SP3 for XP-64. (From the W2K reference you might correctly infer I've been living with Windows for a long time.) –  Ira Baxter Jul 6 '11 at 17:43
    
I've seen your remark, and won't go down that path. Thanks anyway. –  Ira Baxter Jul 6 '11 at 23:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.