Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently replaced a defective hard disk with a new one [ Windows 7 - "A disk read error occured. Press Ctrl + Alt + Del to restart" ]

I have been using the new hard disk with a Windows 7 installation for about 4 days. Now it has started freezing frequently. Sometimes every 2 minutes and sometimes every 10 seconds.

The freeze lasts for anywhere between 10 and 30 seconds during which time the hard disk light is constantly on.

UPDATE: I found lots of this error in the system event log:

The driver detected a controller error on \Device\Ide\IdePort1.

The source is mentioned as "atapi" and the Event ID is 11.

These things happen randomly:

  • Explorer alone freezes and restarts by itself
  • Firefox alone freezes and becomes responsive randomly
  • Half the open windows freeze and become responsive randomly
  • All windows freeze and become responsive randomly

My Efforts

  • I scanned my computer using Microsoft Security Essentials and found nothing malicious.
  • I did a chkdsk /r and found no problems.
  • I did a memory diagnostic and found no problems.
  • When I go into safe mode, it doesn't freeze and I am able to use it normally for longer periods of time.

What other steps can I take to locate the problem?


There is lots of software installed - I am a developer and my PC is full of IDEs, database servers, web servers, developer tools, testing tools, all browsers etc..

BUT my hardware is more than capable of handling the load - Dual Core 2.7GHz, 2GB RAM, GeForce 9400GT and I think a fast and big enough hard disk.

My windows is up to date as of now. I have installed ALL updates including optional drivers etc. All my installed software is up to date.

share|improve this question
What's the hard disk? – Shinrai Feb 8 '11 at 15:26
Seagate 500GB 7200RPM - "ST3500418AS ATA Device" – user57813 Feb 8 '11 at 15:28
up vote 1 down vote accepted

Any errors reported in the system event log? It is possible the new drive has issues.

share|improve this answer
I am getting LOTS of this - The driver detected a controller error on \Device\Ide\IdePort1. Source: atapi; Event ID: 11; – user57813 Feb 8 '11 at 16:16
Maybe your drive wasn't bad, but the controller is? Might be time for a new system board, or at least a new IDE controller card. – DCookie Feb 8 '11 at 16:20
Don't throw the old drive out yet ;-) – DCookie Feb 8 '11 at 16:21
Does that error confirm that the problem is not with the DISK? Is it a problem with the motherboard (or the card) for sure? – user57813 Feb 8 '11 at 16:24
Sure sounds like a controller component issue to me, perhaps even a motherboard issue. You could try adding an IDE controller card to see if that fixes the issue (they're pretty cheap). That's why I said don't throw away the old drive (the one you replaced) yet. Perhaps the issues with it were actually the controller. – DCookie Feb 8 '11 at 16:35

I had this fault. PC would be fine next hard disk light would go on then the PC would lock up. A hard reset was then required. I re-installed the OS and got the same fault. Tried a new hard disk n checked the memory and still the same. Tried colourful language and a good punch to the front of the box but I had given up with it. The PC won. New PC time it was...

I gave the quad core AMD CPU to my girlfriend from this PC and two weeks later she is now getting the same fault. Most help I have seen on the web is for memory/motherboard/disc controller or new disk but in the end for me it was the CPU.

share|improve this answer

try using resource monitor ("C:\Windows\System32\resmon.exe"). Look especially at the disk tab, which will show all disk activity sorted by application.

share|improve this answer

Try using the System File Checker tool. At a command prompt, type 'sfc /scannow' This will check for problems with corrupted system files. (You may need your installation disk).

Secondly, try checking the RAM with Memcheck86.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.