Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a normal-sighted person and I would like to view pages at 100% all the time. I use keyboard shortcuts that involve CTRL a lot, so about twenty times a day I accidentally hit CTRL at the same time that I'm scrolling, which results in the page being reflowed and repainted. This in is annoying because it can take up to 30 seconds to fix the issue, depending on how complex the site layout is. On sites with dynamic layout such as Google Docs the problem is more serious; accidentally hitting CTRL+mouse wheel corrupts the display and forces me to refresh the page entirely, sometimes causing me to loose information in the process.

I would like to either decouple CTRL+mouse wheel from zoom, or disable zoom functionality altogether. This is possible on Firefox by using about:config; is there a similar way to edit detailed settings in Chrome? Would I have access to the detailed settings if I used Chromium instead of Chrome? I'll probably jump ship back to Firefox if I can't solve this problem.

There is a superuser question that asks basically the same thing I'm asking, but for Firefox and Internet Explorer exclusively. Other people on the Chrome forum have had related issues, but none have the same problem. "I would really like it if I could deactivate the auto zoom in/out." had "something with laptops and Windows 7", not the feature built into Chrome. Other people have had PDF specific issues, which doesn't concern me.

I've also tried searching for extensions that allow you to disable the scroll; I had hoped that "Zoom Lock" would have the ability to lock the zoom at 100% and prevent CTRL+scroll wheel from distorting the display, but it doesn't work for my use case.

Google Chrome version 9.0.597.84 (Official Build 72991) Operating System: Ubuntu 10.10

share|improve this question
    
Yes, great question. I just about posted this myself. I'm getting tired of the exact same thing. Almost enough to stop using Chrome, which is a real shame. –  Cody Gray Feb 9 '11 at 10:35
    
Hum, I'm having the exact inverse problem: I would like to be able to zoom in or out using the scrollwhell. Did Chrome remove support for that? (I'm using Chrome for Mac) –  julien_c Jan 13 '12 at 22:35
    
This is so annoying, Google is so not user friendly. –  Registered User Jul 5 '12 at 19:06
    
@julien_c - what about command scroll, does that work for you? –  Peter Nore Jul 6 '12 at 20:05
    
@PeterNore No unfortunately –  julien_c Jul 7 '12 at 7:12

10 Answers 10

It doesn't look like its possible within chrome at this point, but you could do it from the mouse side. Depending on the drivers for your mouse, you could set ctrl-scroll as a "shortcut" to actually do nothing - essentially capturing the combination and throwing it away. Some drivers will even let you specify this for only within a certain application, at which point you'd specify chrome.

Would need more info of OS and mouse to tell this for sure.

share|improve this answer
    
I don't understand how this would work. And if it did, how would it interact with keyboard shortcuts involving the Ctrl key? The asker says he uses those extensively (as do I), and often that's what causes the problem in the first place. Giving up the ability to use keyboard shortcuts isn't really a solution. –  Cody Gray Feb 9 '11 at 10:37
    
I'll have to look into this - I'm on Ubuntu 10.10; I might be able to use xev or something to remap ctrl-scroll on a system level. In-ter-es-ting ... –  Peter Nore Feb 10 '11 at 4:34

I don't know of any way to disable scrolling, but you could use Ctrl+0 to return to 100% at any time--no need to refresh the page.

share|improve this answer
2  
The real problem here is on sites where javascript dynamically determines the layout, in which case Ctrl+0 never even totally corrects the problem. –  Peter Nore Feb 10 '11 at 4:35
    
NoScript can solve that in very short order. –  CarlF Feb 10 '11 at 18:24
2  
Using NoScript on a site like Google Docs where javascript is required is futile. Most dynamic sites no longer support users that disable javascript as studies have shown that less than 2% of all users disable it: developer.yahoo.com/blogs/ydn/posts/2010/10/… . If dynamic sites going to throw development into an arcane, useless cause they'd actually be better off supporting IE6 than supporting users without javascript: marketshare.hitslink.com/browser-market-share.aspx?qprid=2 –  Peter Nore Mar 2 '11 at 16:29

I have been having an almost identical problem. I'm viewing chrome from a laptop with a built in mouse and no actual wheel, but I would touch the mouse a certain way and find it inexplicably zooming in and out of a page. I am not at all what one would call computer savvy but after reading the first answer I started poking around in my device settings. I found the driver for the mouse, poked around a bit more and eventually found an option to disable "pinch zoom", which thus far seems to have fixed the problem.

share|improve this answer

In Firefox the zoom function can be disabled via its corresponding setting in about:config.

For Chrome: I have found a free little application called AlwaysMouseWheel which does the trick. It is made for another purpose (which I find useful too) but does prevent the zooming in Chrome.

For IE: However, that application doesn't disable the zooming. So I am looking around for a solution for that now.

share|improve this answer

There is a solution using AutoHotKey posted on google groups:

Using Logitech Performance Mouse MX...

Downloaded AutoHotKey software

In the AutoHotkey.ahk file, added these to do nothing for Cntrl+MouseWheelScrolling

^WheelDown::return

^WheelUp::return
share|improve this answer
    
Thanks, this answer is what finally helped me not jump out of a window ( although my adult body would not have fit since i probably zoomed int so tiny while on my way there by accident ) –  onedayitwillmake Jun 5 '13 at 3:45
1  
I had this problem big time when using a Magic Mouse in Windows 7 through Parallels. This little script fixed it all. Thanks! –  GJK Jun 12 '13 at 13:28
1  
That's also the best solution I've found. However your example disables this for all application. The following script disables CTRL-Wheel for Chrome only: ; Disable mouse wheel zooming in Chrome #IfWinActive ahk_class Chrome_WidgetWin_1 ^WheelDown::return #IfWinActive ahk_class Chrome_WidgetWin_1 ^WheelUp::return –  Yaba Feb 13 at 16:46
var actionwheel = function(evt){var evt = evt ? evt : window.event;
            if(evt.shiftKey || evt.ctrlKey)
            { 
                evt.preventDefault(); 
                return false;
            }   
        }
                //add mousewheel evento for firefox only
        document.addEventListener('DOMMouseScroll', actionwheel, false);
        document.onmousewheel = actionwheel;//IE        
        document.onDOMMouseScroll = actionwheel;//Firefox
share|improve this answer
    
And what is this supposed to be? –  Oliver Salzburg Jul 25 '13 at 10:26
    
The user asked for a configuration change to solve the problem. How does this code help? –  suspectus Jul 25 '13 at 11:00
    
This looks a lot like JS, but without some context its pretty hard to tell. Greasemonkey? –  Journeyman Geek Jul 25 '13 at 12:07

How to stop mouse wheel zooming instead of scrolling?

Computer panel/mouse/device setting/select touchpad/settings and DISABLE PINCH ZOOM.

Simple and easy. It worked for me.

share|improve this answer

When pressing a hot key that involves the control button, simply pressing the shift key directly after the initial command causes the control to key to "release" and will then disrupt the auto zoom.

A lil bit of an annoyance to add to the work flow, but it's much better than manually doing it every single time.

share|improve this answer

Try with this one

 $(window).keydown(function(event)
{
    if((event.keyCode == 107 && event.ctrlKey == true) || (event.keyCode == 109 && event.ctrlKey == true))
    {
        event.preventDefault();
    }

    $(window).bind('mousewheel DOMMouseScroll', function(event)
    {
        if(event.ctrlKey == true)
        {
            event.preventDefault();
        }
    });
});
share|improve this answer

This was driving me insane as well, but I just found a chrome extension that worked for me (at least on Windows 7):

http://chrome.google.com/webstore/detail/no-mousewheel-zoom/ckhlfagjncfmdieecfekjbpnnaekhlhd?hl=en-US

Looking at the reviews, it did not work for someone using chrome on ubuntu, so your mileage may vary.

share|improve this answer
    
Please see How do I recommend software in my answers? –  G-Man Sep 9 at 22:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.