Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On my work computer, I need to set the proxy for web browsing.

I'd like to use rhythmbox to stream internet radio, but it usually fails with "Cannot resolve the proxy hostname". So, I want to avoid those settings for rhythmbox.

Is there a way to force rhythmbox to use direct connection for internet radio streams? I've tried setting the HTTP_PROXY envar to various values with no help.

Note it works if I revert to direct connect in Firefox or Chrome, then connect the "radio" in rhythmbox. I can then set the browser proxy back to normal, and rhythmbox continues to work -- but I have to repeat the manual process the next time I want to stream audio.

Also, running a local proxy isn't really a solution in this case.

share|improve this question
    
I'm having the same problem. Did you find a solution? – Thomas Jul 4 '11 at 10:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.