Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to run Notepad.exe via Schtasks.

I first created a scheduled task, named "secheduledNotepad".

SUCCESS: The scheduled task "secheduledNotepad" has successfully been created.

Then I tried to run it:

C:\Windows\system32>Schtasks /Run /TN "secheduledNotepad"

It runs, as I receive the message:

SUCCESS: Attempted to run the scheduled task "secheduledNotepad".

and I can even see notepad.exe in Windows Task Manager.

But... it is nowhere to be found on the screen!

Why? and how do I fix this?

(I am using Windows 7 Starter)

share|improve this question
1  
Did you tell it to run under your own user context? – user3463 Feb 9 '11 at 5:04
    
@Randolph Potter How do I tell it to run under my own user context? – WinWin Feb 9 '11 at 14:48
up vote 1 down vote accepted

It is there. Open the task Scheduler and then select Microsoft. Then on the right hand side select Create a task the second on down. That will open it. One the first page down the bottom the last check box. "Run with the highest privileges" Check that.

Good luck, R Scotti

share|improve this answer

I also had this problem. I'm running windows 8.1 The newly created task seems to default to run only if the machine is on AC power. When I unticked the option on the Conditions tab it worked fine.

share|improve this answer
    
Question was for Windows 7, but might be helpful anyway – Thomas Weller Jan 17 '14 at 11:55
    
Understood, but there's not much for 8.1 at the moment so I can't be the only one who'll end up here. :) – user290899 Jan 17 '14 at 12:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .