Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Mac OS X (Snow Leopard 10.6.6) setup on a network with several Windows 7 machines.

When trying to place a large file on a Windows share the connection to the Windows share is lost and I am unable to reconnect until I reboot the Mac. I know this is on the Windows side because the Mac can connect and transfer files to Server 2008 and XP without issue. Looking in the log file I see this message:

SharePointBrowser::handleOpenCallBack returned 12

I have tried restarting the service but that did not resolve the situation. I can do an nslookup to the Windows 7 machine, but trying to ping the machine by hostname always gives a hostname lookup failure (I can ping via IP address).

I cannot connect to the machine via IP adress either.

share|improve this question
Is it a wireless network? Can you put smaller files on the share without any problems? What happens if you reset the Windows network connection after resetting sysagent service? – user3463 Feb 9 '11 at 5:57
It is not a wireless network, smaller files can be copied ok, once the connection to the windows machine drops the mac won't recognize it is there again unless I reboot – Jason Yost Feb 10 '11 at 5:05
FWIW, I'm seeing these exact symptoms on Lion 10.7 (build 11A511). A solution that doesn't require a reboot would be great if anyone's found one. – cduhn Aug 24 '11 at 3:10
I have had this problem connecting to one of my Windows 7 machines for a year now and could never figure it out. – duckworth Dec 11 '11 at 15:20
up vote 0 down vote accepted

I had the same error from Snow Leopard when using a Win7 machine for light file serving duties at home. The Win7 machine had some errors in the event log:

Source: srv
Event ID: 2017
Level: Error
The server was unable to allocate from the system nonpaged pool because
the server reached the configured limit for nonpaged pool allocations.

With that error noted, a search brought me to a solution:

Set the following registry key to ’1′:
HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

and set the following registry key to ’3′:

Explanation of what the reg keys do: (scroll to bottom)

Thanks to Alan LaMielle and Mark Russinovich.

share|improve this answer
So far no problems copying large files. – Jason Yost Jul 21 '12 at 20:49

Most problems situated with being able to connect or not to a windows computer could have the problem lying directly in-front of your eyes, try disabling the firewall, and if that doesn't work, pretty much trial and error until you provide enough detail and information to solve this computer quarrel.

share|improve this answer

I fixed this issue by using the smb protocol. In Finder, you push Ctrl+K and a box will pop up. You then type the following:


This will open up a dialog that will let you select which shared directory you would like to access. From there you can move around in any of the shared folders through Finder.

Be sure that you have the folders you want shared selected as shared in Windows 7. If they're not shared, you won't be able to access those files/folders. It's a bit of a hassle, but it's the only way I found to work around this issue.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .