Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to run simple commands so I can have GeekTool output date/time etc. to my desktop. Should be simple enough to do but it never actually outputs anything into the boxes. Console log shows it's getting spammed by GeekTool to say 'command not found', though the same command (e.g. date +"%H:%M") works fine in Terminal.

All I want to achieve is the ability to output a clock displaying time/date on my desktop that fits into my wallpaper. I've tried changing the format of the commands, using the built-in editor window as well as the command line box on the Properties tab. I had a look at the permissions in '/' (because GeekTool runs commands from there) and nothing unusual comes up. None of these solved the issue. When I use a command that simply echo's a string it works (e.g. echo "hello" displays the word hello).

Does anyone have experience with GeekTool, and understand why it won't run basic commands? As I say, it's spamming my console with 'command not found' despite them working in terminal...

Running OS X 10.6.6 on a MacBook Pro (mid-2010).

share|improve this question

migrated from stackoverflow.com Feb 9 '11 at 10:13

This question came from our site for professional and enthusiast programmers.

1  
Hello and welcome to Super User! Please edit your question; adding the following points may get you better answers: 1. What are you trying to accomplish? 2. What have you tried so far? 3. What results did you get? 4. How did that differ from the results you were expecting? (please be more specific, these are not self-evident from the current state of your question) –  Piskvor Feb 9 '11 at 9:49
    
What about echo $PATH, or using /bin/date +"%H:%M"? –  Arjan Feb 9 '11 at 13:52
    
Did you meanwhile try the above? –  Arjan Feb 14 '11 at 16:48
    
Yes, tried that and it worked! The issue was the path. Using /bin/date was all that was needed. –  Kevin Dowling Feb 15 '11 at 18:22

2 Answers 2

up vote 1 down vote accepted

Try entering whole path for command. You can figure it out by running

which date

in your terminal.

share|improve this answer

You need to use single quotes, so use

date +'%H:%M' 

and it will work :-)

Here is a screenshot, how my Shell geeklet is configured; besides name, position, and "default group" yours should look quite similar:

shell geeklet to display time

share|improve this answer
    
No, that didn't work unfortunately. I tried single quotes originally. Using the feedback status section, it simply returns a red dot... –  Kevin Dowling Feb 9 '11 at 13:42
    
That´s weird - which version of GeekTool are you using? –  Asmus Feb 9 '11 at 14:21
    
I've the latest build... –  Kevin Dowling Feb 14 '11 at 12:58
    
@KevinDowling : I´ve posted a screenshot above, does that help? –  Asmus Feb 14 '11 at 16:37
    
(@Asmus, if that code on the bottom is some license code, then you might want to crop the image?) –  Arjan Feb 14 '11 at 16:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.