Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My Shortcuts on Windows7 was just opening VLC, and I right-clicked one of them to change the default program and it eventually opened. But because I chose for it to always open in the default program, all shortcuts did the same - they opened that same application. Apparently I had associated shortcuts to that application. How do I re-associate shortcuts to act as a shortcut to their own applications? Please help me understand the way shortcuts work in other to rectify the problem. Thanks. Niyimagic

share|improve this question

4 Answers 4

  1. start (click)
  2. search programs (click)
  3. Regedit (you need to write this and open it)
  4. HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.lnk (you need to find these sub-folder by clicking through the keys)
  5. UserChoice (you need to find and delete this folder that's the problem that you made)
  6. Close and restart windows
share|improve this answer
1  
using win-r then regedit would be an easier way to get to regedit. I do suspect you can search registry as well. –  Journeyman Geek Oct 13 '12 at 8:01
    
I know this post is old, but just used it to solve my problem. Thank you for your answer. –  amlane86 Mar 20 at 19:50

Well, in order to try and recreate your problem, I was sitting here with the same problem without any clue how to fix it. When you try to change the file type association again, there is no option to revert to the original state.

How I fixed it eventually is through the use of this website: http://www.sevenforums.com/tutorials/19449-default-file-type-associations-restore.html

There is a howto on the site itself, but the procedure is very simple. Look for the link to LNK filetype on the page, download the zip which include a .reg file. Open that .reg file, agree to the security message and after it is done, log off and on and the .lnk file type will be reassociated to its original state.

share|improve this answer

Right click any file again and choose Open With > Choose default program...

enter image description here

Select the program, and choose Always use the selected program to open this kind of file

enter image description here

share|improve this answer
    
I think he associated program shortcut files with a particular application. Which is useless, no matter what application you choose. –  Daniel Beck Feb 9 '11 at 17:07

Head over to Control Panel\All Control Panel Items\Default Programs\Set Default Programs

Then you can choose each application and set their defaults back

enter image description here

share|improve this answer

protected by Community Mar 17 '13 at 17:18

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.