Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

How do I disable Ubuntu Authenticate popup that is used to elevate privileges?

Please do not put answers telling that this is a security issue, the purpose of this question is how and not why.

share|improve this question
add comment

2 Answers

Added to /etc/sudoers

yourusername ALL=NOPASSWD: ALL

Having been a Unix veteran for 20 years, long before the inception of Ubuntu, I too don't need another lecture about root access, to be found everywhere searching for simple information.

No matter what the docs say, even now with 11.10 the damn popup appears every few minutes when I have dozens of software-center installs queued. So much for trying to get that done overnight.

Another thing I often resort to is sudo -i to a root shell from the terminal to run software-center or other common gui apps (like gparted) that otherwise just love to popup modal password dialogs.

share|improve this answer
add comment

Strange question but here's two ideas:

a) enable root user assigning a password: sudo passwd root

b) log in as root

Another one would be tweak the sudoers file:

Open a terminal and digit:

sudo visudo

And move the big paragraph to the end , remove the # in front of sudo and add yourself to a sudo group

ps If you want to keep it simple add under:

root ALL=(ALL) ALL

yourusername ALL=(ALL) ALL

share|improve this answer
    
I'm really interested about b). Where is the big paragraph you are talking about? –  sorin Feb 9 '11 at 17:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.