Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Yesterday, my external hard drive was working fine. Now, only the boot partition is accessible whilst the main partition with all my files on it is coming up as a raw, empty drive.

I had taken it to a friend's, where I tried to access the files from a Xbox 360 and a PC. For the latter, I installed Ext2Fsd and Ext2 IFS for Windows 7 but didn't do anything that could have resulted in a formatting or loss of files. The hard drive was moved from one house to another but was extremely snug in a backpack and isn't likely to have taken any knocks.

Any clue what has happened and how I can access the files if at all? I only have access to Windows XP. It is a 1TB drive, so I can't even remember half of what's on it, let alone how to replace it!

share|improve this question
add comment

2 Answers

If Windows doesn't recognise the partition format, it will give you a prompt to reformat it should you try to browse the drive. Are you absolutely sure neither you nor your friend ran through this?

I don't believe the 360 would have done anything, again, unless you asked it to.

If you run fdisk or gparted, what does the partition table look like? Has it been changed to fat or is it still ext3 etc. etc. ?

share|improve this answer
    
There definitely wasn't any formatting on either PC or 360. I haven't ever used either program but I can see from the IFS Drives application on the Control Panel, that the boot partition has its name and file system listed whilst the main partition just says it's Linux and nothing else. I assume that means the properties suggesting there's no file system at all is correct then. –  duffers Feb 9 '11 at 20:08
1  
All sorted, thanks to a Google search. For anyone with the same problem, download EXT2FSD, right click the partition or drive that's not being found, and go to service management. Click 'start' on the top right and change the letter of the drive. All should be fine. –  duffers Feb 9 '11 at 20:57
    
ah bah so it was just an ext2fsd issue? when you can, add your own answer rather than the one on this one so you can get some rep :-) –  PriceChild Feb 9 '11 at 21:09
    
Actually, still not out of the woods yet. Though the files are all there, there is apparently 48Gb of space. This is wrong because I only had a gig or two before the trouble and large file transfers cause the computer to crash, citing 'not enough resources' to carry it out. Small files like a JPEG go over fine. Thought I'd post here rather than a new post though perhaps that's a better idea. –  duffers Feb 10 '11 at 21:01
add comment

Have you put the Ext2Fsd and Ext2 IFS on the same drive? Actually, RAW is just a kind of file system that cannot be recognized by Windows or Mac system. Therefore, your drive seems empty. But, your files are still there.

What you need to do is to select a reliable recovery program to regain them and format your drive afterwards. There are many recovery freeware out there. Go search one on the internet.

Note:

  1. Do not store any new file to overwrite the original files, which can make them gone forever.
  2. Do not save the recovered files on the same drive, which can cause recovery failure.
  3. Do not forget to format this drive to make it workable after the recovery stuff.
  4. Do not forget to back up your important files as possible as you can in the future
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.