Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have 3 iMacs and a Windows machine on my home network, all connected via an Airport Extreme router. I'm developing Google App Engine applications locally on one of the iMacs, and can view applications using http://localhost:8080 (or whatever port I choose).

How do I connect to those applications from other iMacs and Windows machines in my network? I've located the IP for the iMac hosting Google App Engine: But when I try from another machine it will not load the page.

share|improve this question

migrated from Feb 9 '11 at 20:58

This question came from our site for system and network administrators.

Please read our FAQs next time. – Chopper3 Feb 9 '11 at 20:58
Can you link this to my account? – Will Curran Feb 9 '11 at 21:40

See docs for the --address option here:


  1. On the machine running appengine: Open System Preferences > Network and write down the IP (eg.
  2. Use this IP with the address option, ie. "--address", when you launch the dev appserver.
  3. Visit from any machine in your local network.
share|improve this answer
Thank you! you saved me lots of time ! – Igor Konoplyanko Mar 29 '11 at 22:59
Sorry I did not see this in time to mark it as the answer. It worked! – Will Curran Apr 16 '11 at 3:41

For those of you finding this page but are running App Engine 1.7.6 or newer, use


instead of


A big update in the Development Server resulted in a large number of options being changed or removed (all shortened flags were removed), as well as python 2.5 support being killed. On the upside, the admin host/port can also be changed with

--admin_host= --admin_port=8000

share|improve this answer

Use the --address option to bind to all addresses:

dev_appserver --address my_app

This will then work from anywhere. The default is to bind to a loopback address only (

share|improve this answer

You must log in to answer this question.