Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Okay, so I have officially tried every solution to an issue I can think of. I have even tried 3 distributions of LINUX, with still the same issue. [even bought Windows 7].

I have been trying to access my school wifi connection for about... 5 months now. 2 weeks into this year I could connect, Last year I could connect, however for 5 months I have been unable. The school wifi technician says he doenst know if he implemented a MAC address block, or not, and won't let me even look to see if he did. So now I am trying to resort to MAC address spoofing.

My issue lies in the fact that i can not seem to get an address to work with my wireless card. Apparently it is incompatible, or some other reason might be preventing me from connecting after changing the mac address [cant even connect to home network if I change it].

Any ideas? My wireless card is an "Intel PRO/Wireless 3945BG network connection offering dual-mode 802.11a/b/g wireless LAN connection. "

Any info would be helpful, thanks.

share|improve this question
    
Does the machine work with other WiFi networks? (unclear from your question) –  edusysadmin Feb 10 '11 at 0:18
    
Yes, it works perfectly under any other wireless connection. Only the school's is giving me an issue. –  Flasimbufasa Feb 10 '11 at 0:23
1  
The school wifi technician doesn't know?! Either he's BSing you or he needs to find another job. –  Joe Taylor Feb 11 '11 at 20:36
    
My thoughts exactly. He was quick to say they don't have one to me, but to my friend he claimed he had no clue. [this was on two different weeks, but problem still existed]. OH also, if you mess with the computer to where you make a .bat file, give it the icon of internet explorer, and put it on the desktop, have it loop and list all files of computer with a blue background, they reformat the computers. –  Flasimbufasa Feb 11 '11 at 20:50
    
@Flasimbufasa Reinstalling is sometimes the quicker option if something is not working... at least if the reinstall is not done manually but using a deployment image ;-) –  Ale 2 hours ago

2 Answers 2

If your hardware doesn't support changing it's MAC address then the easiest solution would be to purchase a new USB 802.11x card. Since the MAC address depends on the NIC a new usb card would do the trick.

Edit:
You can change your MAC address by doing this.

From the command line, log in as root and type;

ifdown eth0
ifconfig eth0 hw ether 00:80:FF:FF:98:F5
ifup eth0

This change will only persist until you reboot, so you probably want to put this in your boot script /etc/init.d/

Credit : http://www.linuxforums.org/forum/suse-linux/24956-clone-mac-address.html

share|improve this answer
    
Whilst I have thought about this, I am unable to purchase a wireless NIC, because I have no money to my name.. Also, my laptop can connect to any other wireless connection... It is just the school's that I am having an issue with.. –  Flasimbufasa Feb 10 '11 at 0:24
    
If there is a Mac address block and you can't change your address (you mentioned it didn't work earlier) then you will not be able to join the network using that NIC unless they remove the block. You can confirm that you have been blocked by having someone else emulate your mac address and see if they have similar issues getting online at your school. –  Daisetsu Feb 10 '11 at 0:29
    
So, a wifi card can accept any mac address? I thought that if the new address didn't have a specific format, it can't be used by the wifi card. –  Flasimbufasa Feb 10 '11 at 0:44
    
I edited the answer. Try what I just suggested, it's too hard to add as a comment. –  Daisetsu Feb 10 '11 at 18:54
    
Thanks.. But for some reason my wireless nic is still rejecting the mac address. apparently there is a format that mac addresses require in order to be accepted by the nic, however I can not find the website anymore. –  Flasimbufasa Feb 11 '11 at 20:09
up vote 0 down vote accepted

I found the answer! Apparently this wireless adapter has a certain format for a new mac address to be accepted.

http://www.sevenforums.com/network-sharing/7090-how-change-mac-address-intel3945bg.html Has more information.

IN short:

0a.23.xx.xx.xx.xx is work but

00.23.xx.xx.xx.xx doesn't work. so sad T-T

root@:# ifconfig wlan0 hw ether 0a:23:74:91:93:F6
root# ifconfig wlan0 
wlan0     Link encap:Ethernet  HWaddr 0a:23:74:91:93:f6  
          inet addr:192.168.2.164  Bcast:192.168.2.175  Mask:255.255.255.240
          inet6 addr: fe80::823:74ff:fe91:93f6/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:83947 errors:0 dropped:0 overruns:0 frame:0
          TX packets:72398 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:107240358 (107.2 MB)  TX bytes:9242348 (9.2 MB)
share|improve this answer
    
An address beginning with 0A (or any other MAC address where bit 1 of the first byte is set [i.e. the second bit from the right when reading in binary has value 1 — for 0A, binary is 00001010, so that bit is 1]) is a locally administered address (i.e. not a MAC address a product you buy will have). Your network driver probably does not allow you to use a "real" MAC address (excepts the real one of the device, of course). Detail about MAC address format on Wikipedia: en.wikipedia.org/wiki/MAC_address#Address_details –  Ale 2 hours ago

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.