Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

UPDATE: RESOLVED - see my answer below

Frequently, while I'm navigating through folders in a Windows Explorer window (Explorer.exe, not to be confused with Internet Explorer), suddenly I'll hear my hard disk start to thrash and my system becomes unresponsive. When I manage to get Task Manager open (Control-Alt-Delete -> Start Task Manager), I can see that Explorer.exe is using rapidly increasing amounts of RAM, from 1.5GB to 2GB and up. If I watch the RAM numbers for a few seconds, Explorer.exe will go up to about 4GB and then it zeros out and starts over. All the while, my hard disk is thrashing and I can't do anything with my computer. I have managed to get back to normal by terminating the Explorer.exe process and then using Task Manager's Run... command to restart Explorer.exe. These episodes keep my system unusable for anywhere from 3 to 5 minutes.

I have been told that this is a virtual memory problem. My virtual memory settings are fine -- they're set to automatic. I have around 10% free space on all of my hard disks.

I tested system files with sfc /scannow and found no problems.

I tested my RAM using Windows Memory Diagnostic and found no problems.

I've noticed the problem occurs specifically when browsing through folders in the Documents library. It happens almost every time I navigate through my frequently used folders, especially if I move through the folders quickly. It often happens when I'm attempting to open Word files.

The system will "freak out," usually for about 2 or 3 minutes. When I'm able to see the RAM usage during the system, it is up at around 98% or even higher.

One possible complication is that I moved the Document Library locations to a different disk (F:), not the same disk that Windows is installed on (C:), but this shouldn't be a problem.

Any ideas?

NEW DETAILS 9/10/11:

I am now experiencing this problem on two different Windows 7 x64 computers. Exactly the same problem occurs on both, with explorer.exe gobbling up all available RAM and slowing the system to a crawl. I believe the following procedure will trigger the problem.

1) Navigate to a folder synchronized with Windows Live Mesh 2011 that contains at least two Word document files.

2) Click (do not double click) one of the Word document files. Then click a different Word document file. Repeat this several times.

3) Perform a file operation. (Delete, copy, or open one of the Word files.)

4) The system will seem to slow down or "freeze" temporarily. If you look at Task Manager, up to 99% or even 100% of RAM will be in use. The explorer.exe process will use rapidly increasing amounts of RAM.

I am more convinced than ever that Windows Live Mesh 2011 is the culprit here. I will uninstall this program and re-test both systems, then update this question with more information. If you have any further insights, please help. Thank you.

Based on excellent suggestions from Superuser, I've done a lot of troubleshooting. Currently, I have mitigated the problem, but I still haven't eliminated it. After clearing the Windows thumbnail cache, the RAM spike and hard disk thrashing I describe above still happens, but the duration of the attack is only about 5 or 10 seconds now (instead of 3 or 5 minutes). Another step that helped was selecting "Launch folder windows in a separate process" in Explorer's Folder Options, on the View tab. This has isolated the troubled window, so that when I need to terminate explorer.exe, my taskbar and desktop aren't usually affected.

share|improve this question
1  
Temporarily boot into safe mode. That will disable all extensions and hooks into Explorer, and see if the problem is still there. –  vcsjones Feb 10 '11 at 2:44
    
I just updated this question with more details. If anyone has more ideas, please let me know. This problem has become worse for me recently and I am still unsure about the cause of the issue. Thanks. –  Mantis Aug 26 '11 at 19:48
1  
What documents are contained in those folders? Does Explorer display thumbnails (previews) of these documents? –  Denis Nikolaenko Sep 5 '11 at 20:07
    
The problem occurs when Explorer is set to show the folders in "details" mode, but the Windows 7 status bar shows previews of the file, anyway, right? –  Mantis Sep 7 '11 at 21:06
1  
Try this procedure and report back to us. –  Tom Wijsman Sep 10 '11 at 15:18
show 3 more comments

6 Answers

Try running Process Monitor or Process Explorer and capture what happens during "normal" operation as well as during the moments when it seems to slow down. That's a way of troubleshooting it.

You could also try uninstalling Live Mesh and see if it makes a difference.

share|improve this answer
1  
Add AutoRuns: Check what extensions (especially third part) that Explorer is loading. –  Richard Feb 10 '11 at 9:46
    
Thanks for these suggestions. I have been systematically disabling Explorer extensions using AutoRuns. Currently, I have disabled all non-Microsoft extensions, and I'm still experiencing the behavior I describe in the original question. The two MSFT extensions still running: EPP (shellext.dll) and "Gadgets" (sbdrop.dll). Should I disable these extensions as well? –  Mantis Sep 4 '11 at 3:10
add comment

Try clearing your thumbnail cache, use disk cleanup to do this.

Also if you have image or especially video files in some of those folders that Windows is unable to generate thumbnails for because it does not have the codec needed, this can cause Explorer issues, slow downs or even crashes.

If you can locate the folders with files that Windows cannot generate a thumbnail for, change the view setting for that folder to something like details, so it will not attempt to generate thumbnails.

If they are MKV video files see this thread

share|improve this answer
    
The problem occurs most often while I'm browsing folders that contain only .doc, .docx, .pptx, and .pdf files. –  Mantis Sep 7 '11 at 21:05
    
Makes me wonder if your security software is causing it, try disabling any active AV software, see if things improve. –  Moab Sep 7 '11 at 22:47
    
Well, the only security software I'm using is microsoft Security Essentials. I've just cleared my thumbnail cache. After testing whether that made a difference, the next thing I'll try is disabling MSE. Thanks again. –  Mantis Sep 8 '11 at 0:56
    
Clearing the thumbnail cache has made an impact. I still see RAM use spike and observe the hard disk thrashing while working with Explorer.exe, but the effect has gone away more quickly since clearing the thumbnail cache. I still don't think this problem is totally solved, though. I'm going to continue troubleshooting until I no longer see any RAM spikes. I'll update the original question. Thanks again for your help. –  Mantis Sep 10 '11 at 16:10
    
I have continued experiencing this issue. My new theory is that the system freezing is caused by browsing folders containing a large number of Word files with saved thumbnail images. I'm going to work on deleting all the Word thumbnails in a folder to see if that has an impact. Alternatively, I'll disable thumbnails in explorer.exe by following the instructions here: social.technet.microsoft.com/Forums/en/w7itprogeneral/thread/… –  Mantis Sep 28 '11 at 18:04
show 3 more comments

I recently discovered that the Windows feature Offline Files can cause the sorts of errors described in this question. I disabled Offline Files about one week ago. I haven't experienced the system instability I described in the question since disabling Offline Files.

To disable Offline Files in Windows 7 (should be the same for Vista):

  1. Click Start and search for "Offline Files." Click "Manage Offline Files."

  2. Click "Disable Offline Files."

share|improve this answer
    
I'd hoped that disabling Offline Files would have fixed this problem, but sadly, I encountered it again, even with Offline Files disabled. I'll keep picking at this (intermittent) problem. Any further ideas would be very helpful. Thanks. –  Mantis Jul 7 '11 at 14:24
    
Provided that you gave the bounty, are you still looking for a solution? –  Tom Wijsman Sep 10 '11 at 15:21
    
Yes. The bounty was set to expire in less than an hour, so I awarded it. I'll add another bounty if I'm able to do so. –  Mantis Sep 10 '11 at 16:21
add comment

Unless there is something instable at a lower level, shell extensions are the main culprit.

Use ShellExView to disable those that are not by Microsoft, you can try re-adding the ones you after...

share|improve this answer
    
Thanks for your suggestion. I think I already successfully disabled all non-Microsoft shell extensions using AutoRuns. That action did not fix the problem. –  Mantis Sep 10 '11 at 16:08
1  
@Mantis: You might want to double check because I believe ShellExView shows non-AutoRun Entries too. –  Tom Wijsman Sep 10 '11 at 16:10
    
OK, Tom. Thanks -- I'll check with ShellExView as well, and I'll report my findings here. –  Mantis Sep 10 '11 at 16:17
    
@Mantis: Also see the comment I left on your own answer, as well as the comment I left on your question. It seems you only read my answer... –  Tom Wijsman Sep 10 '11 at 16:19
add comment
up vote 2 down vote accepted

The problem stems from a memory leak in explorer.exe when it attempts to show file image previews (thumbnails) of Word 2007 files.

I solved the problem by preventing explorer.exe from showing these file image previews. To do so, I edited the Windows registry.

Be careful when editing the registry - if you make a mistake it could cripple your computer. Always back up your registry first, by following these instructions.

To edit the registry:

  1. Click Start and type "regedit.exe." A shortcut to Regedit.exe will appear.
  2. Right-click the shortcut to Regedit, and select "Run as administrator." Provide credentials if necessary.
  3. In Regedit, navigate through the folders listed on the left to the following location:

HKEY_CLASSES_ROOT.dotx\ShellEx{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}

  1. Click on the word "default," and confirm that the value listed is: "{C41662BB-1FA0-4CE0-8DC5-9B7F8279FF97}". (If you see a different value, redo the previous step to make sure you're at the right location in the registry).

  2. Then press the "Delete" key on your keyboard. Confirm the deletion.

  3. Repeat steps 3. and 4. for the following location:

    HKEY_LOCAL_MACHINE\SOFTWARE\Classes.docx\ShellEx{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}

    "default" value: "{C41662BB-1FA0-4CE0-8DC5-9B7F8279FF97}"

More information is available here.

share|improve this answer
    
How did you determine it was the .dotx that was causing the issue? –  Moab Oct 13 '11 at 3:47
    
First, I noticed that I only experienced the issue when browsing folders containing .docx files. Second, clearing the thumbnail cache significantly lessened the duration of the "hang" behavior, but after a few days, the behavior returned to its usual duration (2-3 minutes). Finally, I determined that the thumbnails for Word files must be the problem, and I set out to find a way to disable these thumbnails only. After disabling .docx (and .dotx) thumbnails, I have not experienced the issue again. I believe this is a bug in explorer.exe. –  Mantis Oct 18 '11 at 14:04
add comment

The problem might be the search indexing in Windows 7.

The article Disable Search Indexing In Windows 7 shows how to disable it definitively, and explains :

In order to speed up the search process, the Search indexing service scans through the files and folders on the Windows system and records information about them in an index file. But it also consumes some resources of the system, so for the users with a slow computer it is beneficial to turn off search indexing.

You might try first to disable this service, as explained in the article, to see if this is the problem. If it is not, then re-enable it. If it is, then keep reading below.

More information can be found in Improve Windows searches using the index: frequently asked questions :

Indexed locations include all folders included in libraries (anything you see in the Documents library, for example), e‑mail, and offline files. Files that aren't indexed include program files and system files—files that most people rarely need to search.

The problem in this case might be that your libraries include very many files that the Indexer requires too much memory to index. Maybe this is just a simple bug with one particular document that it keeps looping on. You could use the information in the second article section "How do I add or remove index locations" to reduce the number of folders that are being indexed until you find the problematical library.

share|improve this answer
    
I think you might be right that the search indexer is the problem, but do you think that the search indexer would cause explorer.exe to hang while I was just browsing folders? Explorer.exe will "freak out" when I'm just clicking through folders in my Documents library. Also, I use Windows search extensively, so I would prefer to keep the indexer active. Is there any way to determine if there is a particular file that's causing the problem, rather than just turning off the search indexer completely? Thanks for your help. –  Mantis Sep 4 '11 at 18:29
1  
Turning off indexing can be a temporary measure just to verify if this is really the problem. Afterward, find out which library contains the bad document(s) by removing them from search. If any one library cause the problem, finding out which document(s) could be a matter of binary search (move out half of the files, then a quarter, etc). Alternatively, you could use instead a replacement for Windows Search, such as Everything search engine or Agent Ransack or FileLocator Lite. –  harrymc Sep 4 '11 at 18:56
    
OK, I'll try disabling the Windows search indexer for a while and see if I still encounter the trouble behavior. I'll report my results here shortly. Thanks again. –  Mantis Sep 4 '11 at 19:45
    
Unfortunately the problem behavior repeated itself again, even while the search indexing process was disabled. The episode seemed to resolve itself a bit faster than usual (the computer was unresponsive for only about 60 seconds, instead of the usual ~3 minutes). Still, I was browsing using Explorer, in the folders where this problem tends to happen, and again the RAM usage and disk thrashing all occurred again. Thanks for the suggestion, but the problem has not been solved yet. Any other ideas? –  Mantis Sep 7 '11 at 21:16
    
Does this problem happen when you boot in Safe Mode ? –  harrymc Sep 8 '11 at 6:23
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.