Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using putty to ssh to a unix server I can't see any colours is one major annoyance also, if I press home/end, backspace etc it doesn't work.

I tried changing the Keyboard configuration, but none of the combinations I tried worked.

any ideas?

share|improve this question
add comment

migrated from stackoverflow.com Feb 10 '11 at 4:42

This question came from our site for professional and enthusiast programmers.

1 Answer

up vote 2 down vote accepted

What type of server? Linux? Solaris? Something else?

For each key, the aim is to have tput <key name> produce the same output as pressing
Ctrl+V <key>.

  1. Log on to your server
  2. Run echo $TERM
    • it should say xterm or putty
  3. Run tput kbs | cat -v
    • if it says ^H, change PuTTY settings so backspace sends ^H
    • if it says ^?, change PuTTY settings so backspace sends ^?
    • if it prints an error message, and you have TERM=putty, run TERM=xterm and try again
  4. Run tput khome | cat -v
    • tell us the output and we can figure out which setting you need

See Configuring PuTTY for some hints and more details.

share|improve this answer
    
server is Solaris (SunOS,Sun-Fire-V215), tput kbs | cat -v gave ^H, I set putty backspace to ^H, backspace is working now, but the delete key is still showing ~ khome kbs | cat -v gave ^H, I set the Home and End keys to rxvt, home is working now, end is not doing anything. I have the Functions Keys and keypad set to XtermR6, the keypad (i.e. when I switch off the Num Lock) seems to be working ok –  Charbel Feb 10 '11 at 10:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.