Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm using Comcast, and I'm using a Linsys WRT54G2 router. I'm testing a MegaUpload Premium download using jDownloader and it is just staying at 15 or 16kbps. There is clearly a problem there. How can I fix this?

My speed tests from speakeasy and speedtest.net are getting 5mbps - 7mbps download with 3.5mbps upload

share|improve this question
    
You may want to test your connection speed at speedtest.net to see whether your connection is at fault or MegaUpload simply applies bandwidth restriction. –  oKtosiTe Feb 10 '11 at 9:12
    
Try connecting a computer directly to your modem, bypassing the router. This should help you isolate the problem. –  Mr Alpha Feb 10 '11 at 11:53
    
What have you tried so far? –  Kyle Feb 10 '11 at 16:07
add comment

4 Answers 4

up vote 1 down vote accepted

There was an issue with the signal. My signal was at -19 dbmv. You can check this in your diagnostics throu the cable modem, 192.168.100.1. In this situation, you have to call Comcast and get them out here to fix it.

share|improve this answer
    
Since this seems to be related to your router (correct me if I am wrong), it would have matched my answer and the corresponding comments, or not? –  Michael K Mar 13 '12 at 16:44
add comment

Have you checked the port security and bandwidth options of your router?

share|improve this answer
    
and jDownloader settings –  Phil D. Feb 10 '11 at 8:49
    
It's happening in Chrome too, so its not because of a the program. Also in Firefox. –  Doug Feb 10 '11 at 16:36
    
Like I said, I suggest you to check your router settings. –  Michael K Feb 11 '11 at 8:59
add comment

First, what is your Internet Connection type? Is it good? You should check line parameters if you have ADSL.

Second, Linksys WRT54G2 with stock firmware is impossible to bandwidth management. So please check another file sharing hosts, such as mediafire.com, etc.. to make sure about problem with Megaupload.

Third, check your firewall app or any shaping traffic app you may have in your computer.

share|improve this answer
add comment

I was able to fix this issue with Comcast by powering my router off for 30 seconds, powering the modem off for 30 seconds, then renewing the IP address (certain routers will let you renew your public IP on demand). This happens to me about once every 6-8 months, according to the the tier 3 tech(which I finally escalated to) The DNS cache needs to be refreshed, he had no permanent fix for me...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.