Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a WD Elements 1.5TB External Hard Drive. It is under 2 months old, and it sits on my desk and has not been moved. A few days ago, it started appearing in Windows Explorer as "Local Disk F:" and when I click on it, after a very long pause, it would tell me that I need to format it.

The only thing that I can think of that might have caused this is me pulling out the USB cable without ejecting it, but if I had done that, it would not have been while I was transferring data to or from it.

Is there anyway to make it work again without losing all the data on it?

If it helps, I am Running Windows 7 Pro 32bit.

Edit: When I view it in Disk Managament, it says that the filesystem is RAW and that 100% of space is free.

I sometimes also get the error message F:\ is not accessible. The parameter is incorrect. when trying to view it in Windows Explorer

share|improve this question
    
What filesystem you were using? NTFS or FAT32 or something else? –  Olli Feb 10 '11 at 9:34
    
I'm assuming it was NTFS, which I think is a fairly safe assumption. Just checked it in Disk Management, and it says the file system is RAW. Not looking good. –  DanielGibbs Feb 10 '11 at 9:36

4 Answers 4

up vote 1 down vote accepted

I face same error for my transcend 250 GB Ext HDD. it display same error and i also use win 7 32-bit. I have solved it when i attached it on another computer. Than again attached with my computer. But you try this and do one more thing check drive for errors like chkdsk /f F: where F: is drive letter. i am sure solved it.

share|improve this answer
    
Please don't post irrelevant links (especially ones that can be construed as spam). Check the FAQ –  ChrisF Feb 10 '11 at 12:23
    
Thanks! The chkdsk thing fixed it. But apparently it has 4 KB in bad sectors. Will this affect me in the future at all? –  DanielGibbs Feb 10 '11 at 19:44

I had a external hard disk which after a power failure behaved like that. The only way I could revive it was to take the actual disk out of the disk enclosure and plug it directly into a windows machine (as a second hard disk) and restart the machine. When windows was starting up, it was able to perform a chkdsk and fix the problem.

I was then able to plug the disk back into the enclosure and use it a external drive again.

This worked for about a year and then the drive starting failing and this trick didn't help.

share|improve this answer
    
Thanks for that, I'll try that soon, and let you know how it went. –  DanielGibbs Feb 10 '11 at 10:16

Does it have an external power supply? If so is it plugged in and turned on?

Try it on a different USB, some of my USB keys will prompt for a format in one but not the one just below it.

Failing that try it on another machine.

If neither work, you may need for format it. Then see if it does the same thing again after a while (I wouldn't store important stuff on it for a while until you can be confident in it again). If it does happen again it may be a dud and you should look into the warranty.

share|improve this answer
    
Yes, the power supply is plugged in and turned on. It just occurred to me that there might have been a power cut in the last 2 months, would that have effected it? And I have tried all 4 USB ports on my computer, and no change. I'll try it on another machine later and update this then. –  DanielGibbs Feb 10 '11 at 9:48

If it's under warranty, I'd return it as dud and get another. If not, then try repartitioning and reformatting, and see what you get.

I personally would be very suspicious of a disk that has gone bang once, as that's usually the sign of a dying device.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.