Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have two identically sized partitions on my laptop's hard-drive (A and B we'll call them) so that when I'm ready to upgrade to a new major release of my OS on A, I can copy A to B for backup purposes, upgrade A and run on A from there. If something goes wrong, I copy B back to A and start over.

Problem is, I'm unable to use GParted to copy partitions anymore. I select my source partition in GParted and hit the Copy button and all seems good. The problem is, GParted will not let me select Paste no matter what I do. Both partitions are unmounted, and I've tried deleting the destination partition first and then selecting it, but Paste is still disabled.

I tried using parted (instead of GParted), and get the following:

(parted) cp /dev/sda 2 1
Error: File system has an incompatible feature enabled.  Compatible features are has_journal, dir_index, filetype, sparse_super and large_file.  Use tune2fs or debugfs to remove features.

I'm using a GParted live CD that has parted v1.8.8 and GParted v0.4.3.

Just for giggles, I downloaded the newest GParted live CD and had the exact same problem. However, there I was unable to run parted because GParted no longer defaults to the root user when you start a console, and I don't know the root password. Nice. I'll deal with that later.

So, what am I doing wrong?

According to GParted:

    /dev/sda1    ext3    48.35GiB
    /dev/sda2    ext3    48.35GiB
    unallocated          7.38MiB
    /dev/sda3    swap    5.74GiB
    /dev/sda4    extended
      /dev/sda5  ext3    46.61GiB

How can I copy sda2 to sda1 here?

share|improve this question

migrated from stackoverflow.com Feb 10 '11 at 19:18

This question came from our site for professional and enthusiast programmers.

1 Answer 1

I think the error is quite self explanatory:

(parted) cp /dev/sda 2 1
Error: File system has an incompatible feature enabled.  Compatible features are has_journal, dir_index, filetype, sparse_super and large_file.  Use tune2fs or debugfs to remove features.

Run:

tune2fs -l /dev/sda2

to see what features you have enabled which aren't listed in the above. You can then think about disabling some.

The other option is dd but I don't think we want to go there...

share|improve this answer
    
You're most likely correct, but honestly, this is just sloppy. gparted needs to support ext3 already. It's been years... –  Jay Nov 17 '11 at 16:19
    
gparted supports ext3 perfectly well in my experience. Run the command I suggest and lets see what options you have enabled :-) –  PriceChild Nov 23 '11 at 16:26

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.