Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've been connecting to the internet through a LAN-cable, all I needed to do was give my ISP the mac-address of my eth-card and it works.

Now i want to bridge the connection through a router to enable internet sharing through wifi, I've got a Thomson Speedtouch 585 v6 with firmware running on it. I need to somehow enable a eth-port as a dhcp-client, set the mac-address on it and then use the routers wifi to work as a dhcp servder for my wireless computers so they can access the internet.

Anyone with some insight on this?

share|improve this question
I've been looking throught the manual with little success, perhaps I just need to get a bigger book on networks. Little dissapointing that this is not thought of as a standard feature. – Vésteinn Feb 10 '11 at 19:46
up vote 2 down vote accepted

Found this!

Firmware version 6.1 or higher:

:ppp relay flush
:ppp flush
:eth flush
:atm flush
:atm phonebook flush
:eth bridge ifdelete intf=ethport4
:eth ifadd intf=eth_wan
:eth ifconfig intf=eth_wan dest=ethif4
:eth ifattach intf=eth_wan
:ip ifadd intf=ip_wan_eth dest=eth_wan
:ip ifconfig intf=ip_wan_eth status=up
:ip ifconfig intf=ip_wan_eth hwaddr=00:11:42:0c:65:1d <-- This line is only needed if you need MAC address cloning
:ip ifattach intf=ip_wan_eth
:nat ifconfig intf=ip_wan_eth translation=enabled
:dhcp client ifadd intf=ip_wan_eth
:dhcp client ifconfig intf=ip_wan_eth metric=5 dnsmetric=5
:dhcp client rqoptions add intf=ip_wan_eth option=dhcp-lease-time
:dhcp client rqoptions add intf=ip_wan_eth option=dhcp-renewal-time
:dhcp client rqoptions add intf=ip_wan_eth option=dhcp-rebinding-time
:dhcp client rqoptions add intf=ip_wan_eth option=subnet-mask
:dhcp client rqoptions add intf=ip_wan_eth option=classless-static-routes
:dhcp client rqoptions add intf=ip_wan_eth option=default-routers
:dhcp client rqoptions add intf=ip_wan_eth option=classfull-static-routes
:dhcp client rqoptions add intf=ip_wan_eth option=domain-name-servers
:dhcp client ifattach intf=ip_wan_eth

It works brilliantly. Thanks to, just remember to update the firmware!

share|improve this answer

The user's guide for your router can be found here (PDF):

Based on a quick look at the device, I don't think it can do what you need it to. There are two issues:

  1. The device is intended to use the dsl port as the WAN port, so the factory firmware won't support dhcp to just the remaining ports. More importantly, it only supports the layer 3 (router) functions you need to route packets correctly between the local network and public internet between the ports on the lan side of the device and the dsl port on the WAN side. It won't know how to treat one of the lan ports as your internet connection.
  2. All the LAN ports likely have the same mac address, and this device is unlikely to support mac spoofing.

That said, you might get lucky and it could work out one of two ways:

  1. A more thorough reading of the linked document might prove me wrong (though I doubt it).
  2. You might be able to load something like dd-wrt, open-wrt, or tomato on the device, at which point you have a pretty good chance of making this work.

Also, you can get a wireless router off the shelf for <$40 just about anywhere that will do this, or for <$20 if you know where to look online ( or amazon would both do this).

share|improve this answer
I updated the firmware to enable this, the manual is outdated since a lot more options are available, it's just such a cluster of abreviations I can't get my head around it. I can set any port as wan through the CLI. The device supports mac-spoofing. So, I'm fairly sure it can do what I want it to do with the right tweaks and enough time, unless of course someone has solved this issue before or knows of a good scheme for these kind of things. – Vésteinn Feb 10 '11 at 19:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .