Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So recently I did a very stupid thing and accidentally deleted my APPDATA, and now the favorite folder doesn't work anymore.

The favorite folder I am refering to is the one in windows explorer in windows 7, which appears on the left of windows explorer windows.

The %USERPROFILE%/Favorite folder still works correctly, but the favorite folder in the shell doesn't point there, instead it points to a nonexistant and broken location, how do i fix this problem?

share|improve this question

3 Answers 3

Is it in the recycle bin? if so restore it. Or,

Try a Microsoft System Restore, pick a date before you deleted that folder.

http://www.howtogeek.com/howto/11238/using-system-restore-to-recover-your-windows-7-computer/

EDIT:

I found a way to remove Favorites from Windows Explorer, maybe you can restore it using these instructions. If the shell folder is missing you may have to create it or get a copy of it from another W7 PC.

HKEY_CLASSES_ROOT\CLSID{323CA680-C24D-4099-B94D-446DD2D7249E}\ShellFolder

  1. )To get permissions, first right-click on "ShellFolder" key and select "Permissions". It'll open a new window.

  2. ) Select "Administrators" in user list and check "Allow" box given for "Full Control" permission.

  3. ) Click on OK button to apply the changes.

  4. Now double-click on "Attributes" DWORD value given in right-side section and change its value to a9400100

  5. That's it. Log off or restart your system and "Favorites" will no longer present in Explorer window.

NOTE: If you want to restore "Favorites" in Navigation pane, simply change value of "Attributes" DWORD to a0900100 using step 4.

.

share|improve this answer
    
Not worth it, the latest recovery date is right after I made a bunch of huge changes to the computer, recovering to that would do more damage than when I deleted the appdata folder. –  Razor Storm Feb 10 '11 at 21:55
    
Check my edit above. –  Moab Feb 10 '11 at 22:22
    
Hmm tehse allow me to delete the favorites folder, and although it might also allow me to redirect the folder, I don't know what hex number to put in for that purpose. I also modified the HKEY_CURRENT_USER/software/microsoft/windows/explorer/shell_folders/favorites key and put in the desired path E:/Users/myUsername/favorites, but it didnt work. –  Razor Storm Feb 11 '11 at 2:00
    
Might be best to create a new user account and migrate your old profile to the new account. When you are happy with the new one, delete the old user account. –  Moab Feb 11 '11 at 2:16
    
is the entirety of your user account information stored in /user/username ? Or are some settings scattered randomly across other folders? –  Razor Storm Feb 11 '11 at 4:18

Change the location in which it points to; to the Favorites folder that you need it to be.

share|improve this answer
    
There's no option in the context menu –  Razor Storm Feb 10 '11 at 21:52
up vote 0 down vote accepted

I figured it out, the problem is that it isn't the "favorites" folder that should be restored, it was the links folder. Favorites folder is for favorites in internet explorer, links folder is for favorites in windows explorer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.