Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In IE 9 RC or in beta, the embedded video is not shown in the web page. I verified the security settings in "internet options". Did not find any issue. Please find the screen shot below. I am able to view the flash videos in Youtube. But, for some reason, in some sites the embedded video is not shown.

I don't have this issue with Firefox.

enter image description here

UPDATE:
I am able to see view the embedded video in Admin account. But not able to view it in Standard account.

UPDATE:

@TomWij, Thanks for the suggestions. The Process Monitor hint helped to nail down the issue. When run with standard privileges, it is getting "ACCESS DENIED" for reading the key

HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/x-shockwave-flash.  

When I elevated the privilege to Admin account, it did not have any issue. Then I uninstalled flash, deleted the registry key and then installed flash again. Now, I am able to view the embedded video in standard account.

share|improve this question
    
possible duplicate...superuser.com/questions/244204/ie9-rc-just-displays-blank-pages –  Moab Feb 11 '11 at 0:29
    
I tried the solution of enabling software rendering instead of GPU accelaration. Still I don't see the embedded video. –  Jagannath Feb 11 '11 at 3:25
1  
Well, it's beta/RC software for a reason –  Sathya Feb 11 '11 at 7:23
    
You've accepted my solution, what step did help you? Also, the bounty is still running, do you need something more or did you forget to assign it? –  Tom Wijsman Feb 14 '11 at 11:39
    
Oh, you've updated your answer (please note that this does not inform me so I didn't saw that), nice job on using Process Monitor! :-) –  Tom Wijsman Feb 14 '11 at 11:42

4 Answers 4

up vote 2 down vote accepted
+50

I've checked, it works here so it's a local issue for you.

enter image description here


Let's work from bottom to top:

  1. Reset your Internet Explorer settings, this should get any odd settings that bug you gone.

    enter image description here

    I suspect is that embedding is disabled, as in my screenshot above, it is a YouTube video.

  2. Uninstall Java, Flash and Shockwave; then uninstall Internet Explorer. Then reinstall.

  3. Try different versions from Flash to check for Compatibility issues.

  4. Disable your Virus Scanner and Firewall to ensure that they aren't bothering you.

  5. As it works as administrator, use Process Monitor and filter the Status on ACCESS DENIED.

    This allows you to troubleshoot what key the iexplore.exe process can't access.

  6. Updating graphics drivers won't work. I'm out of options, it's a RC, live with it...

share|improve this answer

I'd recomend uninstalling flash and reinstalling it. The flash install is different for FireFox than it is for IE so switching between the two will not give apples to apples comparisons.

I've noticed with the IE9 beta/RC Flash 10.2 works better than 10.1.

share|improve this answer

I've just open following this page which installed Flash in my Internet Explorer 9.

My video seems to be working fine in Internet Explorer 9 now...

So, install flash and enjoy.

share|improve this answer

The answer above about access to the registry key

HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/x-shockwave-flash

also works for me. Even easier than above, I just right-clicked on the key in regedit, and allowed all users on the machine read-access to it, and then the embedded videos worked for non-admin users, for example: Shuttle launch seen from airplane window

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.