Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Possible Duplicate:
Wrapping word configuration in mac

I don't know if it's supposed to work like on Windows, but some apps like Chrome, Firefox are doing this as expected and some, like XCode or Text Edit not.

Example, double click on newRectangle word

factory.newRectangle(320, 0, 1, 480)

Chrome, Firefox: selects only newRectangle word.

XCode, TextEdit: selects all this: factory.newRectangle.

Is there a way to set that up?

share|improve this question

migrated from Feb 11 '11 at 2:11

This question came from our site for professional and enthusiast programmers.

marked as duplicate by Daniel Beck, studiohack Mar 17 '11 at 15:11

This question was marked as an exact duplicate of an existing question.

I'd give 15 points to know why this question was rated -1. – Murgh Feb 8 '11 at 19:03
Ok, looks like somebody else bumped it up to 1 point. Still no answers though. – Murgh Feb 8 '11 at 21:27
FWIW, I get the chrome/firefox behavior in xcode 3.2.5 64bit os x 10.6.6 – xdumaine Mar 17 '11 at 11:47
@roviuser See the linked topic. You probably have a different setting than Murgh. – Daniel Beck Mar 17 '11 at 14:01

See the answer I gave on this Superuser question. Basically you need to set this up for all Cocoa applications (like XCode and TextEdit).

Yours, Asmus

share|improve this answer
Thanks for trying to help but it doesn't work with xCode. Still selects across dots. – Murgh Feb 9 '11 at 14:39
Did you really restart XCode? Also: which version are you using? Because it works for me under XCode 3.2.5! – Asmus Feb 9 '11 at 14:50
Yeah, I CMD-Q'd and reopened. I have 3.2.2 - 64 bit. Still selects across dots. – Murgh Feb 9 '11 at 19:26