Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have just installed the Linux distro Pardus, with its KDE desktop. I already had a home directory(on a separate /home) partition so I just created the user and tried to logon. The problem is, when I log on using KDM, noe of the KDE stuff works, no desktop, no bars etc., only one xterm without any decorations. When I try to launch any X11 application, I get "cannot open display %s" while my $DISPLAY is :0

I renamed my home folder and created an empty one, that worked perfectly. So I have at least one dot-file that breaks my desktop settings. I have no .kde or .kde4 folders. All the ideas on what might be breaking my desktop is welcome. I was previously using Gnome desktops so I have fairly big .config, .gnome, .gconf etc directories.

share|improve this question
up vote 1 down vote accepted

I resolved it with the following steps: First create an empty home folder and login via that one. See everything works.

mv /home/atilla /home/atilla.bak mkdir /home/atilla

Then start moving stuff that cannot possibly harm.(All the non dotfiles)
Pay special attention to .kde, .kde4 and .config folders.

Delete everything that is unnecessary. Move the dot folders one by one and check each if anything breaks.

It took some time but worked eventually.

Addendum: the most important trouble is ~/.xinitrc If you have one, read carefully. Experimenting with renaming that file is very fruitful.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .